Defect #11355

Plain text notification emails content is HTML escaped

Added by Arnis Juraga over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Email notifications
Target version:2.1.0
Resolution:Fixed Affected version:2.0.3

Description

There are some problems with latest Redmine versions.
After upgrade to 2.0.2 (the same problem with 2.0.3), when sending e-mail notifications as PLAIN TEXT, something has changed.

Now - "<pre>" tag is replaced with &lt;pre&gt;

There are some other issues with incoming e-mails as well, but this is another issue.


Related issues

Duplicated by Redmine - Defect #12138: Plain Text Emails are Html Escaped Closed

Associated revisions

Revision 10205
Added by Jean-Philippe Lang over 5 years ago

Fixed that text email templates are escaped (#11355).

History

#1 Updated by Toshi MARUYAMA over 5 years ago

  • Category set to Email notifications
  • Affected version (unused) set to 2.0.3
  • Affected version set to 2.0.3

#2 Updated by Etienne Massip over 5 years ago

  • Subject changed from Redmine 2.0.2 e-mail notifications parsing to Plain text notification emails content is HTML escaped
  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

#3 Updated by Etienne Massip over 5 years ago

  • Description updated (diff)

#4 Updated by Etienne Massip over 5 years ago

Bad news: this is a Rails issue, more specifically a 3.x issue regression according to original LH ticket.

Good news: the issue has been reopened 14 days ago and a PR is being worked on (or, at least it was 8 days ago) so it could be fairly well fixed soon.

#5 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from Confirmed to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next minor release to 2.1.0
  • Resolution set to Fixed

Etienne Massip wrote:

Good news: the issue has been reopened 14 days ago and a PR is being worked on (or, at least it was 8 days ago) so it could be fairly well fixed soon.

The ticket was closed on github. That's odd because I'm still able to reproduce with Rails 3.2... Patch applied in r10205 anyway.

Also available in: Atom PDF