Patch #13460

All translations: RSS -> Atom

Added by Filou Centrinov over 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:2.4.0

Description

Replace for all language translations "RSS" with "Atom".

translation_rss_to_atom.diff Magnifier - translate all locales (92.2 KB) Daniel Felix, 2013-03-13 11:37

functional_renaming_rss_to_atom.diff Magnifier - rename all methods and give deprecation warnings (26.9 KB) Daniel Felix, 2013-03-13 11:37

translation_rss_to_atom_v2.diff Magnifier (92.2 KB) Daniel Felix, 2013-03-13 21:08


Related issues

Related to Redmine - Patch #15118: Deprecate and rename rss_* methods to atom_* methods New

Associated revisions

Revision 11654
Added by Jean-Philippe Lang over 5 years ago

All translations: RSS -> Atom (#13460).

Patch by Daniel Felix.

History

#1 Updated by Mischa The Evil over 5 years ago

I think the patch is missing, but it speaks for itself...

#2 Updated by Daniel Felix over 5 years ago

Hi I'll provide two patches.

Number 1: just the renaming of RSS in ATOM in all translations. I checked it quickly to prepent that only feed-keys are updated. It seems to be okay.

Number 2: functional renaming. Deprecation of old rss_* methods and redefining them as atom_* methods. Old methods are still available and give deprecation warnings. Please test Number 2, too. But it seems to work in the first test.

Best regards,
Daniel

#3 Updated by Daniel Felix over 5 years ago

  • Target version set to 2.3.0

#4 Updated by Filou Centrinov over 5 years ago

The translation should be "Atom" instead of "ATOM".

#5 Updated by Daniel Felix over 5 years ago

Well this shouldn't be a big problem. Just a simple replace. ;-)

#6 Updated by Daniel Felix over 5 years ago

Any regressions on this patches?

#7 Updated by Jean-Philippe Lang over 5 years ago

  • Category changed from Translations to Code cleanup/refactoring
  • Target version changed from 2.3.0 to 2.4.0

I've committed the translations in r11654 but I think it's a bit late to change the methods for 2.3.0.

#8 Updated by Daniel Felix over 5 years ago

Yes your right.
I just added 2.3 as a sidenote for the translations. :-)

Hopefully the way I use to deprecate those methods is good enough for the implementation. :-)

#9 Updated by Jean-Philippe Lang about 5 years ago

  • Target version changed from 2.4.0 to Candidate for next major release

2.4 feature freeze

#10 Updated by Toshi MARUYAMA about 5 years ago

  • Status changed from New to Closed
  • Target version changed from Candidate for next major release to 2.4.0

r11654 changed all translations.

#11 Updated by Mischa The Evil about 5 years ago

  • Category changed from Code cleanup/refactoring to Translations

I extracted #15118 out this issue to cover the actual deprecation and renaming of the affected methods, which makes that this issue is about the translations only (like as it was initially).

#12 Updated by Mischa The Evil about 5 years ago

  • Related to Patch #15118: Deprecate and rename rss_* methods to atom_* methods added

Also available in: Atom PDF