Feature #1365

Allow Project by Project setting of a 'Default' Tracker value including nil

Added by James Byrne almost 10 years ago. Updated almost 2 years ago.

Status:NewStart date:2008-06-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

Presently the 'default' tracker value is determined by its UTF-8 encoding so that the tracker with lowest alphabetic value description displays and is selected automatically if the user does not alter it. I suggest that the default tracker be settable by project and that a nil default be available which would mean that the user MUST select one tracker value from the available list but that none will be preselected for them.


Related issues

Related to Redmine - Patch #1667: Default tracker setting in each project New 2008-07-21
Related to Redmine - Feature #23309: Automatickly default tracker in new issue from issues list New
Duplicated by Redmine - Feature #21392: Make Tracker field to be empty by default Closed
Duplicated by Redmine - Feature #14018: Allow tracker field appear empty on new issues' creation ... Closed

History

#1 Updated by Thomas Lecavelier almost 10 years ago

  • Target version deleted (0.8)

The target version field has to be set when it will actually part of the target release.

#2 Updated by Bobby Birks about 9 years ago

I second this request. There's a great tendency to forget to select an appropriate tracker when a default is provided. Our development group has had to move dozens of issues between trackers over time as a result of this.

Also, since I can't add related issues, I'll just point out the related patch in #1667

#3 Updated by Lucas CORBEAUX over 7 years ago

I totaly agree : it's really easy in Redmine to set a wrong tracker with the default choice, and such feature would be great for data's consistency.

#4 Updated by Grégoire COUTANT over 7 years ago

I agree too and the patch seems to "resolve" this feature. Could you it put in the next release ?

#5 Updated by Ján Regeš over 6 years ago

Hi.

This patch isn't executable in Redmine version 1.2.2.

Is there a handy man to create this feature as a Redmine plugin? I'm new to Ruby :-(

Thank you.

Jan

#6 Updated by Pavel Kholyavkin almost 6 years ago

Can you implement this patch to Redmine? It would be great!

#7 Updated by Maciej Liżewski over 3 years ago

Any updates in this area? Default tracker could really help...

#8 Updated by Toshi MARUYAMA about 3 years ago

  • Subject changed from Allow Project by Project setting of a 'Default' Tracker value encluding nil to Allow Project by Project setting of a 'Default' Tracker value including nil

#9 Updated by John David Heinzmann over 2 years ago

+1
Badly needed for reasons cited above.

#10 Updated by budo kaiman over 2 years ago

+1

#11 Updated by Sebastian Paluch over 2 years ago

+1

#12 Updated by Go MAEDA over 2 years ago

  • Duplicated by Feature #21392: Make Tracker field to be empty by default added

#13 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicated by Feature #14018: Allow tracker field appear empty on new issues' creation (force user to choose tracker) added

#14 Updated by Tobias Fischer almost 2 years ago

This ticket should be closed as a duplicate of #1667 which already includes a patch for this.
Hopefully #1667 can make it in the next release...

#15 Updated by Toshi MARUYAMA almost 2 years ago

  • Related to Feature #23309: Automatickly default tracker in new issue from issues list added

Also available in: Atom PDF