Defect #17579

Edit Watchers List Loses Checked Watchers When Performing Multiple Searches

Added by Brandon Liles almost 4 years ago. Updated 2 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:2.4.2

Description

When editing the watchers list on an issue, if you search for a user, click their name but do not click "Add", and then perform a new search, the clicked contact is lost.

It would be more intuitive if checked watchers were not lost by doing a new search. The search could filter the user list client-side instead of requiring server round trips, and this would prevent the clicked contacts from being lost.


Related issues

Related to Redmine - Patch #28771: Allow adding multiple entities when performing multiple s... New
Duplicated by Redmine - Defect #18916: Adding Multiple Watchers - Doesn't add when you re-search... Closed
Duplicates Redmine - Defect #17071: Adding Watchers UX Is Not Clean New

History

#1 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Defect #17071: Adding Watchers UX Is Not Clean added

#2 Updated by Mischa The Evil over 3 years ago

  • Duplicated by Defect #18916: Adding Multiple Watchers - Doesn't add when you re-search users. added

#3 Updated by James H over 3 years ago

+1 in 2.6.0

I think it would be good if either the system "remembers" previously checked options or the system adds or removes watchers in "real-time" as the user is clicking.

#4 Updated by Luka L├╝dicke over 1 year ago

I tested the patch from #17071#note-1 (which is two years old) and it fixes the issue. When will it be applied?

btw: that is a good example where the select2 widget could provide a elegant solution https://select2.github.io/examples.html#multiple

#5 Updated by Marius BALTEANU 2 months ago

  • Related to Patch #28771: Allow adding multiple entities when performing multiple searches in modals added

#6 Updated by Marius BALTEANU 2 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I've added some proposals to fix this behaviour in #28771.

I'm closing this ticket as duplicate of #17071.

#7 Updated by Marius BALTEANU 2 months ago

  • Related to deleted (Defect #17071: Adding Watchers UX Is Not Clean)

#8 Updated by Marius BALTEANU 2 months ago

  • Duplicates Defect #17071: Adding Watchers UX Is Not Clean added

Also available in: Atom PDF