Feature #17618

Upgrade net-ldap version to 0.12.0

Added by Francois Conil over 3 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:LDAP
Target version:3.2.0
Resolution:Fixed

Description

The net-ldap gem is being updated again and is now at version 0.7.0

Our tests so far show no issues from either LDAP auth or accounts imports.

It's a minor change that can easily be done manually, but I assume it would be "nice to have" for future redmine versions.


Related issues

Related to Redmine - Feature #12811: ASCII-8BIT to UTF-8 problems -update net-ldap with net-ld... New

Associated revisions

Revision 14783
Added by Toshi MARUYAMA about 2 years ago

upgrade net-ldap gem to 0.10.1 (#17618)

Revision 14784
Added by Toshi MARUYAMA about 2 years ago

upgrade net-ldap gem to 0.12.0 (#17618)

History

#1 Updated by Francois Conil over 3 years ago

The title should be "version". 'doh.

#2 Updated by Toshi MARUYAMA over 3 years ago

  • Category set to LDAP
  • Priority changed from Low to Normal

#4 Updated by Toshi MARUYAMA over 3 years ago

  • Subject changed from upgrade net-ldap bersion in Redmine Gemfile to upgrade net-ldap version in Redmine Gemfile

#5 Updated by Etienne Massip over 3 years ago

  • Target version set to Candidate for next minor release

#6 Updated by Etienne Massip over 3 years ago

  • Related to Feature #12811: ASCII-8BIT to UTF-8 problems -update net-ldap with net-ldap-1 -v0.4.0 added

#7 Updated by Alexander Ryabinovskiy over 2 years ago

As I can see, with net-ldap > 0.3.1 does not work login autocomplete (on user creation screen) for users with russian characters in the name. Redmine 3.1.0.

#8 Updated by Toshi MARUYAMA about 2 years ago

  • Subject changed from upgrade net-ldap version in Redmine Gemfile to upgrade net-ldap version to 0.12.0
  • Target version changed from Candidate for next minor release to 3.2.0

#9 Updated by Jean-Philippe Lang about 2 years ago

  • Subject changed from upgrade net-ldap version to 0.12.0 to Upgrade net-ldap version to 0.12.0
  • Status changed from New to Closed
  • Resolution set to Fixed

Also available in: Atom PDF