Feature #19829

Delete multiple issue attachments at the same time in a transaction during editing

Added by Mikhail Voronyuk over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Attachments
Target version:-
Resolution:Duplicate

Description

Sometimes it is necessary to delete more than 1 attachment from an issue. That causes several journal entries and several emails to watchers.
So from my point of view it would be great to have an option to delete attachments "in a transaction": you press "edit", delete attachments, submit. One journal entry, one email. You could cancel editing and the attachments would not be changed. That would be also helpful if you would like to comment why are you deleting the files.

In my practice than necessity to delete several files at the same was in the cases:
  1. you receive an email by Redmine where several useless inline pictures were attached.
  2. (while using redmine helpdesk plugin) you forgot to activate flag "send mail to supportclient" and had attached several attachments to the issue. You have to delete them and write an journal entry again and activate the flag.

Related issues

Duplicates Redmine - Feature #13072: Delete multiple attachments with one action Closed

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #13072.

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Feature #13072: Delete multiple attachments with one action added

Also available in: Atom PDF