Defect #2038

Italics in wiki headers show-up wrong in the toc

Added by David Holm about 6 years ago. Updated about 4 years ago.

Status:ClosedStart date:2008-10-16
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:1.1.0
Resolution:Fixed Affected version:

Description

When using italics in a wiki header they will show up with the underscore characters printed in the toc.

Steps to reproduce:

Produce a new wiki page as such:

h1. My New Page

{{toc}}

h2. _Subheader_

Expected result:

Subheader should be shown as "Subheader" in the toc.

Actual result:

The underscores are printed in the toc and Subheader is shown as "_Subheader_"

2038_git.diff Magnifier (2.04 KB) Jean-Baptiste Barth, 2010-06-20 21:03

Associated revisions

Revision 4376
Added by Jean-Philippe Lang about 4 years ago

Extract headings and TOC parsing from the textile formatter.

Fixes #2038 and #3707 and will allow to support TOC with other text formatters.

History

#1 Updated by David Holm about 6 years ago

Oops, "who" in the defect subject should be "show"! ;)

#2 Updated by Mischa The Evil almost 6 years ago

  • Subject changed from Italics in wiki headers who up wrong in the toc to Italics in wiki headers show-up wrong in the toc

Corrected subject, wrapped wiki-source in pre-tags and added headings to make the issue more readable...

#3 Updated by Jean-Baptiste Barth over 4 years ago

  • Affected version (unused) changed from 0.7.3 to devel
  • Affected version deleted (0.7.3)

Reproduced on devel branch. Seems similar to #5445 resolved yesterday, I think this is a larger issue, all inline styles are not displayed correctly in TOC...

#4 Updated by Muntek Singh over 4 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Testing this shows fixed by #5445. Marking as closed.

#5 Updated by Muntek Singh over 4 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (Fixed)

Scratch that, I'm stupid

#6 Updated by Jean-Baptiste Barth over 4 years ago

Attached a temporary patch to fix it, but I don't think it should be committed for the moment.

As discussed on the IRC channel, maybe {{toc}} should be completely rewritten since it's similar to a macro in some way, and in some way not (especially for #3707). Plus, this patch does not handle the case of "redmine links" in titles (fixing it the same way would provoke "stack level too deep" errors..).

#7 Updated by Jean-Philippe Lang about 4 years ago

  • Status changed from Reopened to Closed
  • Target version set to 1.1.0
  • Resolution set to Fixed

Fixed in r4376.

Also available in: Atom PDF