Defect #21021

Copying a Redmine issue does not allow change of Status

Added by Roger Noble about 2 years ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:3.0.1

Description

Although the form presented allows selection between existing status and default status, if the existing status is "Closed", the change is not accepted. As a result, the new Issue is created with the Status = Closed and the changes to Subject and Description not done.


Related issues

Related to Redmine - Feature #23610: Reset status when copying issues Closed

History

#1 Updated by Olivier Houdas almost 2 years ago

You should check your workflow (Administration\Workflow) for your role in the project in which you are testing.
I tested with an issue in a project on my test site, and it works perfectly fine, the copied task is changed from Closed to New.

#2 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Needs feedback
  • Priority changed from High to Normal

#3 Updated by Roger Noble almost 2 years ago

Have tried again with the same result.

I've modified the workflow to allow all users to change status from Closed to New. I can modify an existing Closed issue to New. But the copy does not allow the change. It accepts selection from dropdown but does not do the change.

The Redmine version is: 3.0.1.stable.

#4 Updated by Toshi MARUYAMA almost 2 years ago

I cannot reproduce, too.
I cannot see problem this code.
source:tags/3.0.6/app/models/issue.rb#L805

Please give us plugins you used.
See Submissions.

#5 Updated by Go MAEDA 5 months ago

#6 Updated by Go MAEDA 5 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Fixed

Fixed by #23610 for upcoming Redmine 3.4.0.
Issue status is reset to default when an issue is copied and you can choose from all allowed statuses for a new issue.

Also available in: Atom PDF