Defect #21219

Date pickers images for start/due date fields are not shown for issues with subtasks

Added by Marius BALTEANU about 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:3.1.4
Resolution:Fixed Affected version:3.1.1

Description

Precondintion:
Assure that you have in admin the setting "Parent task attributes > Start date / Due date" set to "Independent of subtasks"

Steps to reproduce:
  1. Add a new issue
  2. Add a subtask to that issue
  3. Return to the parent issue
  4. Edit
  5. Observe that the fields start date and due date are shown, but the images for date pickers are missing.

Attached date_pickers.png.

Installation details:
Environment:
Redmine version 3.1.1.stable.14617
Ruby version 2.1.5-p273 (2014-11-13) [x86_64-linux]
Rails version 4.2.4
Environment production
Database adapter Mysql2

Tried without any plugin installed and the same behavior.

date_pickers.png (4.75 KB) Marius BALTEANU, 2015-11-11 16:45

0001-Display-calendar-for-dates-independent-of-subtasks.patch Magnifier (1.21 KB) Codruț Gușoi, 2015-12-09 12:05


Related issues

Duplicated by Redmine - Defect #24698: "Icon for Datepicker" does not appear if the issue has a ... Closed

Associated revisions

Revision 14973
Added by Jean-Philippe Lang almost 3 years ago

Display calendar for dates independent of subtasks (#21219).

Patch by Codrut Constantin Gusoi.

History

#1 Updated by Marius BALTEANU about 3 years ago

The issue reproduces also on 3.1.2 version.

#2 Updated by Codruț Gușoi almost 3 years ago

I've attached a patch with the fix.

#3 Updated by Marius BALTEANU almost 3 years ago

Tested the patch on 3.1.2 and the issue is fixed.

#4 Updated by Toshi MARUYAMA almost 3 years ago

  • Target version set to 3.2.1

#5 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version changed from 3.2.1 to 3.1.4
  • Resolution set to Fixed

Thanks.

#6 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from Resolved to Closed

#7 Updated by Go MAEDA almost 2 years ago

  • Duplicated by Defect #24698: "Icon for Datepicker" does not appear if the issue has a child issue (or issues). added

Also available in: Atom PDF