Patch #23108

Change Japanese translation for text_git_repository_note

Added by Go MAEDA 9 months ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:3.4.0

Description

I suggest changing the translation from "Bare、かつ、ローカルリポジトリ" to "ローカルのベアリポジトリ".

  • In official Japanese reference of Git v1 v2 , "bare repository" is translated as "ベアリポジトリ", not "bareリポジトリ".
  • Current translation have a little bit strange feeling.

ja_translation_fix_text_git_repository_note.diff Magnifier (929 Bytes) Go MAEDA, 2016-06-19 10:45

Associated revisions

Revision 15573
Added by Jean-Philippe Lang 9 months ago

Change Japanese translation for text_git_repository_note (#23108).

Patch by Go MAEDA.

Revision 15579
Added by Jean-Philippe Lang 9 months ago

Removes #23108 from CHANGELOG (#23108, #23109).

Revision 16032
Added by Toshi MARUYAMA 4 months ago

Japanese translation for text_git_repository_note changed (#23108)

History

#1 Updated by Jean-Philippe Lang 9 months ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang

Committed, thanks.

#2 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

  • Current translation have a little bit strange feeling.

See #9129.

#3 Updated by Jean-Philippe Lang 9 months ago

  • Status changed from Closed to Reopened
  • Assignee deleted (Jean-Philippe Lang)
  • Target version deleted (3.3.0)

Change reverted for 3.3.0. I let you see with Toshi how to handle this.

#4 Updated by Toshi MARUYAMA 9 months ago

  • Target version set to 3.4.0

I think this issue can be postponed to 3.4.0.
I have added note to #23109#note-1.

#5 Updated by Go MAEDA 9 months ago

Toshi MARUYAMA wrote (#23109#note-1):

r15573 (#23108) changed "Bare、かつ、ローカルリポジトリ" to "ローカルのベアリポジトリ".
This is regression of #9129 that changed English "Bare and local repository" to "Repository is bare and local".

"ローカルのベアリポジトリ" means not "Repository is bare and local" ("リポジトリはbareかつローカルです"). It means "local and bare repository". "ベアリポジトリ" is one word in Japanese, so "Bare、かつ、ローカルリポジトリ" seems to be strange.

#6 Updated by Toshi MARUYAMA 9 months ago

I think "ベア(bare)なローカルリポジトリ" is better.

#7 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

Toshi MARUYAMA wrote (#23109#note-1):

r15573 (#23108) changed "Bare、かつ、ローカルリポジトリ" to "ローカルのベアリポジトリ".
This is regression of #9129 that changed English "Bare and local repository" to "Repository is bare and local".

"ローカルのベアリポジトリ" means not "Repository is bare and local" ("リポジトリはbareかつローカルです"). It means "local and bare repository". "ベアリポジトリ" is one word in Japanese, so "Bare、かつ、ローカルリポジトリ" seems to be strange.

Yes. But I thought "リポジトリはBareでローカル" is more strange in Japanese at five years ago (#9129).

#8 Updated by Go MAEDA 9 months ago

Toshi MARUYAMA wrote:

I think "ベア(bare)なローカルリポジトリ" is better.

The expression "ベアなリポジトリ" and "ベアなローカルリポジトリ" are not so typical. Google returns only 1 result for "ベアなリポジトリ".
https://www.google.co.jp/webhp?hl=ja&ictx=2&sa=X&ved=0ahUKEwjBiPjfi7TNAhWDVZQKHRfEDhMQPQgD#hl=ja&q=%22%E3%83%99%E3%82%A2%E3%81%AA%E3%83%AA%E3%83%9D%E3%82%B8%E3%83%88%E3%83%AA%22

Yes. But I thought "リポジトリはBareでローカル" is more strange in Japanese at five years ago (#9129).

I agree with you about this. And I think "Bare、かつ、ローカルリポジトリ" is also not so natural. So I have suggested changing it to "ローカルのベアリポジトリ". "ローカルのベアリポジトリ" expressing "bare and local", isn't it?

#9 Updated by Toshi MARUYAMA 9 months ago

There were many FAQs "Why Redmine does not work on non bare?" (#9129#note-6).
So it is "bare and local", not "local and bare".
"ローカルのベアリポジトリ" means "local bare repository".
I cannot accept.

#10 Updated by Go MAEDA 9 months ago

Toshi MARUYAMA wrote:

There were many FAQs "Why Redmine does not work on non bare?" (#9129#note-6).
So it is "bare and local", not "local and bare".
"ローカルのベアリポジトリ" means "local bare repository".
I cannot accept.

It is very clear that "ローカルのベアリポジトリ" saying that repository should be bare. Please explain why this is unacceptable?

#11 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

It is very clear that "ローカルのベアリポジトリ" saying that repository should be bare. Please explain why this is unacceptable?

Shared repository should be bare. So bare is more important than local.
There is remote bare repository.

#12 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

Toshi MARUYAMA wrote:

I think "ベア(bare)なローカルリポジトリ" is better.

The expression "ベアなリポジトリ" and "ベアなローカルリポジトリ" are not so typical. Google returns only 1 result for "ベアなリポジトリ".
https://www.google.co.jp/webhp?hl=ja&ictx=2&sa=X&ved=0ahUKEwjBiPjfi7TNAhWDVZQKHRfEDhMQPQgD#hl=ja&q=%22%E3%83%99%E3%82%A2%E3%81%AA%E3%83%AA%E3%83%9D%E3%82%B8%E3%83%88%E3%83%AA%22

"bareなリポジトリ" hits 225 results.
https://www.google.com/search?q=%22bare%E3%81%AA%E3%83%AA%E3%83%9D%E3%82%B8%E3%83%88%E3%83%AA%22

#13 Updated by Go MAEDA 9 months ago

Toshi MARUYAMA wrote:

Go MAEDA wrote:

It is very clear that "ローカルのベアリポジトリ" saying that repository should be bare. Please explain why this is unacceptable?

Shared repository should be bare. So bare is more important than local.
There is remote bare repository.

"ローカルのベアリポジトリ" says "local", there is no possibility of misunderstanding.

#14 Updated by Go MAEDA 9 months ago

#15 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

"ベアリポジトリ" is more common. We can see 1610 results.
https://www.google.co.jp/search?q=%22%E3%83%99%E3%82%A2%E3%83%AA%E3%83%9D%E3%82%B8%E3%83%88%E3%83%AA%22

I think 1610 results is NOT common.
And I think "bare" should not be translated to "ベア" because it is confusing with bear.

#16 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

"ローカルのベアリポジトリ" says "local", there is no possibility of misunderstanding.

If the person does not know "bare".

$ git init repo

Then, "Why does Redmine not work?"
-> "Because you didn't use --bare option."

But, in case of "ベア(bare)なローカルリポジトリ".
"What is bare?"
"Oh, I see. I need to use --bare option."

"ベア(bare)なローカルリポジトリ" reduces misunderstanding than "ローカルのベアリポジトリ".

#17 Updated by Go MAEDA 9 months ago

Toshi MARUYAMA wrote:

"ベア(bare)なローカルリポジトリ" reduces misunderstanding than "ローカルのベアリポジトリ".

How about changing it to "ベアリポジトリ(ローカル)"? Official git website uses "ベアリポジトリ" and the term is very common, so googling about it is very easy for everyone.

I feel "ベアなリポジトリ" strange.

#18 Updated by Toshi MARUYAMA 9 months ago

Go MAEDA wrote:

I don't think it is official.
It is one of arbitrary translations.
https://github.com/progit/progit/blame/2d5a6cfa9f94028be6f96c03cf2138c7655a0e46/ja/04-git-server/01-chapter4.markdown#L9
There is no official Japanese translation.
https://github.com/git/git/tree/cf4c2cfe52be5bd973a4838f73a/po
Simplified Chinese has official glossary.
https://github.com/git/git/blob/cf4c2cfe52be5bd973a4838f73a35d3959ce2f43/po/zh_CN.po#L26

bare repository | 纯仓库

#21 Updated by Toshi MARUYAMA 9 months ago

  • Description updated (diff)

#23 Updated by Toshi MARUYAMA 9 months ago

Toshi MARUYAMA wrote:

There is no official Japanese translation.
https://github.com/git/git/tree/cf4c2cfe52be5bd973a4838f73a/po
Simplified Chinese has official glossary.
https://github.com/git/git/blob/cf4c2cfe52be5bd973a4838f73a35d3959ce2f43/po/zh_CN.po#L26

bare repository | 纯仓库

"用語集作成スレ"
https://github.com/progit/progit2-ja/issues/29

#25 Updated by Go MAEDA 9 months ago

Toshi MARUYAMA wrote:

Accepted.
https://github.com/progit/progit2-ja/commit/34a99ee963a50225c9baa61e14ace6d52164b49a

Nice work. Can you accept "ローカルのベア(bare)リポジトリ" as a new translation for text_git_repository_note?

#26 Updated by Toshi MARUYAMA 4 months ago

Committed in trunk r16032, thanks.

#27 Updated by Toshi MARUYAMA 4 months ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF