Defect #23206

Wrong filters are applied when exporting issues to CSV with blank filter

Added by Go MAEDA 7 months ago. Updated 7 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues filter
Target version:3.2.4
Resolution:Fixed Affected version:3.2.1

Description

Steps to reproduce:

1. Go to "Issues" page.
2. Clear "Status" check box in "Filters" and click apply. You will see all (open and closed) issues in the project.
3. Export issues to a CSV file by clicking "CSV" link. The CSV file should contain open and closed issues, but actually it contains open issues only.

No problem in 3.1-stable. Maybe this is a regression caused by #22108.

Attached a patch to fix this problem.

fix_csv_export_when_issues_filter_is_blank.diff Magnifier - patch (977 Bytes) Go MAEDA, 2016-06-30 08:30

fix_csv_export_when_issues_filter_is_blank_v2.diff Magnifier - patch v2 (1.5 KB) Go MAEDA, 2016-06-30 16:37

Associated revisions

Revision 15608
Added by Jean-Philippe Lang 7 months ago

Wrong filters are applied when exporting issues to CSV with blank filter (#23206).

Patch by Go MAEDA.

History

#1 Updated by Toshi MARUYAMA 7 months ago

  • Target version changed from Candidate for next minor release to 3.2.4

#2 Updated by Go MAEDA 7 months ago

Updated tests.

#3 Updated by Jean-Philippe Lang 7 months ago

  • Category set to Issues filter
  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Committed, thanks for this patch.

#4 Updated by Jean-Philippe Lang 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF