Defect #23979

Elements are not aligned properly in issues table for some cases

Added by Marius BALTEANU about 1 year ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:3.4.0
Resolution:Fixed Affected version:3.3.0

Description

To reproduce the bellow issue:
  • Sort the issues by parent task
  • Resize the screen until the Assignee goes also on two lines
  • Have at least on parent issue with a subject on two lines
  • Have a child issue with a short subject.

The attached patch fixes this.

I chose to change from top to middle for all table.list td because I don't see any side effect of this change. If it's not ok, i can update the patch to target only the table.list.issues td

issue_list_before.png (150 KB) Marius BALTEANU, 2016-10-04 00:40

issue_list_after.png (146 KB) Marius BALTEANU, 2016-10-04 00:45

vertical_align_middle.patch Magnifier (928 Bytes) Marius BALTEANU, 2016-10-04 00:46

related_before.png (54.6 KB) Marius BALTEANU, 2016-10-04 02:13

related_after.png (52.8 KB) Marius BALTEANU, 2016-10-04 02:15

Associated revisions

Revision 15962
Added by Jean-Philippe Lang 11 months ago

Elements are not aligned properly in issues table for some cases (#23979).

Patch by Marius BALTEANU.

History

#1 Updated by Marius BALTEANU about 1 year ago

Also, the related issue section from issue page can benefits from this change.
before:

after:

#2 Updated by Toshi MARUYAMA 12 months ago

  • Target version set to 3.4.0

#3 Updated by Jean-Philippe Lang 11 months ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch committed, thanks.

#4 Updated by Mischa The Evil 4 months ago

  • Subject changed from Elements are not aligned properly in issues table for some cases to Elements are not aligned properly in issues table for some cases

Also available in: Atom PDF