Patch #2607

Avatars display in forums

Added by Brad Beattie almost 9 years ago. Updated almost 8 years ago.

Status:ClosedStart date:2009-01-28
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

90%

Category:Forums
Target version:-

Description

Not sure what format you want your patches in, so I'll just include this here.

app/views/messages/show.rhtml from release 0.8.0, between lines 32 and 33

<%= avatar(message.user, :size => "32") %>

application.css Magnifier - public/stylesheets/application.css (modified from 0.8.0) (22.3 KB) Brad Beattie, 2009-01-29 22:50

show.rhtml Magnifier - app/views/messages/show.rhtml (modified from 0.8.0) (3.2 KB) Brad Beattie, 2009-01-29 22:50

application.css Magnifier - public/stylesheets/application.css (22.4 KB) Brad Beattie, 2009-01-29 22:54

avatars.patch Magnifier (1.58 KB) Brad Beattie, 2009-02-05 07:55


Related issues

Related to Redmine - Feature #4468: Show gravatar images in forum view Closed 2009-12-22

History

#1 Updated by Brad Beattie almost 9 years ago

Kay, just went and tested this idea out. Two changes.

message.user didn't work, but message.author does. Change app/views/messages/show.rhtml between lines 32 and 33:

<%= avatar(message.author, :size => "32") %>

The avatars need to float left. Include .message img.gravatar in public/stylesheets/application.css on line 645

#history img.gravatar,
.message img.gravatar {

#2 Updated by Brad Beattie almost 9 years ago

Hrm. On one-line posts, this can cause the subsequent message h4 to indent incorrectly.

#3 Updated by Brad Beattie almost 9 years ago

Brad Beattie wrote:

Hrm. On one-line posts, this can cause the subsequent message h4 to indent incorrectly.

Well, clear: left is certainly an option, but that would require the contextual div to be included in the message div. That makes sense as that's how journal divs are working now and consistency is awesome like that.

#4 Updated by Brad Beattie almost 9 years ago

#5 Updated by Brad Beattie almost 9 years ago

  • Assignee set to Jean-Philippe Lang
  • % Done changed from 0 to 90

Okay, done. I just need someone to review it and integrate it if appropriate.

#6 Updated by Brad Beattie almost 9 years ago

Minor clear: left fix.

#7 Updated by Jean-Philippe Lang almost 9 years ago

Brad, you should submit your changes using a single patch file.
It's much more easy to review and apply.
You can generate a patch file using svn diff command.

#8 Updated by Brad Beattie almost 9 years ago

Right you are, good sir. When I made this ticket I was still getting into the swing of things.

#9 Updated by Oshyan Greene almost 8 years ago

Is this planned for inclusion in a future version? The forums are a bit hard to read at the moment without visual poster identity context. This would help a lot. Thanks!

#10 Updated by Felix Schäfer almost 8 years ago

  • Status changed from New to Closed

As far as I can tell, this is a dupe of #4468, which has been fixed in 0.9.0.

Also available in: Atom PDF