Defect #27863

If version is closed or locked subtasks don't get copied

Added by Alessandro Zucchi 7 months ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Issues
Target version:3.4.6
Resolution:Fixed Affected version:3.3.5

Description

Hi,
if I tryed to copy an issue with subtasks only the parent task is copied if the source version is closed or locked.
Regards
Alessandro

0001-Clear-target-version-when-copying-an-issue-if-status.patch Magnifier (2.12 KB) Marius BALTEANU, 2018-06-04 23:24


Related issues

Related to Redmine - Defect #28765: Copying an issue fails if the issue is watched by a locke... Closed
Copied to Redmine - Defect #28946: If assignee is locked subtasks don't get copied Closed

Associated revisions

Revision 17368
Added by Go MAEDA about 1 month ago

Clear target version when copying an issue if status is locked or closed (#27863).

Patch by Marius BALTEANU.

Revision 17369
Added by Go MAEDA about 1 month ago

Merged r17368 from trunk to 3.4-stable (#27863).

History

#1 Updated by Toshi MARUYAMA 6 months ago

  • Status changed from New to Confirmed
  • Priority changed from Urgent to Normal

Confirmed.
In the log:

Could not copy subtask #70 while copying #71 to #74 due to validation errors: Target version is not included in the list

I don't know what expected behaviour should be.

#2 Updated by Alessandro Zucchi 6 months ago

Hi,
for me all children issues must be copied independently from the state of the version, not only the parent task.s

Regards
Alessandro

#3 Updated by Go MAEDA 2 months ago

  • Related to Defect #28765: Copying an issue fails if the issue is watched by a locked user added

#4 Updated by Marius BALTEANU 2 months ago

  • Target version set to Candidate for next minor release

Toshi MARUYAMA wrote:

Confirmed.
I don't know what expected behaviour should be.

Considering that the target version is cleared in the UI when you copy an issue with a locked/closed target version, I think we should keep the same behaviour also for subtasks and automatically clear the target version if it is locked/closed. Any other opinions?

#5 Updated by Alessandro Zucchi 2 months ago

Marius BALTEANU wrote:

Toshi MARUYAMA wrote:

Confirmed.
I don't know what expected behaviour should be.

Considering that the target version is cleared in the UI when you copy an issue with a locked/closed target version, I think we should keep the same behaviour also for subtasks and automatically clear the target version if it is locked/closed. Any other opinions?

Ok clear the target version if it is locked/closed, but most important that get copied.
Alessandro

#6 Updated by Marius BALTEANU about 1 month ago

Attached is a small patch that fixes this issue.

#7 Updated by Marius BALTEANU about 1 month ago

  • Copied to Defect #28946: If assignee is locked subtasks don't get copied added

#8 Updated by Go MAEDA about 1 month ago

  • Target version changed from Candidate for next minor release to 3.4.6

The patch submitted by Marius works fine. Setting target version to 3.4.6.

#9 Updated by Go MAEDA about 1 month ago

  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed. Thank you all for your contribution.

Also available in: Atom PDF