Defect #28109

Incorrect interpolation in Swedish locale

Added by Felix Schäfer 19 days ago. Updated 19 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:3.3.7
Resolution:Fixed Affected version:

Description

There is an incorrect interpolation in the Swedish locale file in source:/trunk/config/locales/sv.yml@17186#L137

28109.patch Magnifier (812 Bytes) Felix Schäfer, 2018-01-31 11:10


Related issues

Related to Redmine - Patch #18587: Swedish translation (updated) Closed

Associated revisions

Revision 17188
Added by Toshi MARUYAMA 19 days ago

fix interpolation in Swedish locale (#28109)

Contributed by Felix Schäfer.

Revision 17190
Added by Toshi MARUYAMA 19 days ago

Merged r17188 from trunk to 3.4-stable (#28109)

fix interpolation in Swedish locale.

Contributed by Felix Schäfer.

Revision 17191
Added by Toshi MARUYAMA 19 days ago

Merged r17188 from trunk to 3.3-stable (#28109)

fix interpolation in Swedish locale.

Contributed by Felix Schäfer.

History

#1 Updated by Felix Schäfer 19 days ago

  • File 28109.patch added

The attached patch fixes the problem on trunk/master.

#2 Updated by Felix Schäfer 19 days ago

Felix Schäfer wrote:

The attached patch fixes the problem on trunk/master.

It turns out this was only half the problem, in addition to the % being at the wrong place for the interpolation, there is also an issue with the variable used for the interpolation being the wrong one. This new patch fixes both issues.

Thank you Jan for catching the second issue!

#3 Updated by Marius BALTEANU 19 days ago

  • File deleted (28109.patch)

#4 Updated by Go MAEDA 19 days ago

  • Related to Patch #18587: Swedish translation (updated) added

#5 Updated by Go MAEDA 19 days ago

  • Target version set to 3.3.7

Confirmed the broken message. Setting target version to 3.3.7.

#6 Updated by Toshi MARUYAMA 19 days ago

  • Subject changed from Incorrect interpolation in swedisch locale to Incorrect interpolation in Swedish locale

#7 Updated by Toshi MARUYAMA 19 days ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Committed in trunk, 3.4-stable, and 3.3-stable, thanks.

locale:check_interpolation cannot catch nested keys, so I could not catch this mistake.
source:tags/3.4.4/lib/tasks/locales.rake#L58

Also available in: Atom PDF