Patch #31320

Set an appropriate default type in New custom field page depending on the current tab

Added by Mizuki ISHIKAWA 3 months ago. Updated about 12 hours ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Custom fields
Target version:4.1.0

Description

If "New custom field" link is pressed while selecting the Activities tab in custom_fields/index, the default value of radio_button on the next screen is "Issue".

I think that it is convenient if the default value of radio_button of the next screen is Activities.

The attached patch changes the default value of radio_button according to the tab opened in the previous screen.

custom_fields.png (165 KB) Mizuki ISHIKAWA, 2019-05-08 09:09

change-default-value.patch Magnifier (2.93 KB) Mizuki ISHIKAWA, 2019-05-08 09:10


Related issues

Related to Redmine - Defect #31896: Admin screen - "New custom field" button does not work if... Closed

Associated revisions

Revision 18156
Added by Go MAEDA 3 months ago

Set an appropriate default type in New custom field page depending on the current tab (#31320).

Patch by Mizuki ISHIKAWA.

Revision 18372
Added by Go MAEDA about 12 hours ago

Fix that "New custom field" button does not work if there are no custom fields (#31896, #31320).

Patch by Mizuki ISHIKAWA.

History

#1 Updated by Go MAEDA 3 months ago

  • Category changed from UI to Custom fields
  • Target version set to 4.1.0

It is a small but nice improvement. Setting the target version to 4.1.0.

#2 Updated by Go MAEDA 3 months ago

  • Subject changed from Change the default value of radio_button in custom_fields/select_type to Set an appropriate default type in New custom field page depending on the current tab
  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thanks.

#3 Updated by Go MAEDA 3 months ago

  • Target version deleted (4.1.0)

#4 Updated by Go MAEDA 3 months ago

  • Target version set to 4.1.0

#5 Updated by Marius BALTEANU 3 days ago

  • Status changed from Closed to Reopened

An issue was reported in #31896.

#6 Updated by Marius BALTEANU 3 days ago

  • Related to Defect #31896: Admin screen - "New custom field" button does not work if there are no custom fields added

#7 Updated by Go MAEDA about 12 hours ago

  • Status changed from Reopened to Closed

Marius BALTEANU wrote:

An issue was reported in #31896.

Fixed in r18372.

Also available in: Atom PDF