Patch #31433

Use "icon icon-*" classes for sort-handler, collapsible fieldsets and collapsible versions

Added by Marius BALTEANU 5 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Code cleanup/refactoring
Target version:4.1.0

0001-Use-the-regular-icon-icon-classes-for-sort-handler.patch Magnifier (3.92 KB) Marius BALTEANU, 2019-05-23 19:58

0002-Use-the-regular-icon-icon-classes-for-collapsible-fi.patch Magnifier (4.8 KB) Marius BALTEANU, 2019-05-23 19:58

0001-Fix-missing-icons.patch Magnifier (5.09 KB) Marius BALTEANU, 2019-05-29 23:36

0002-Use-icon-icon-classes-for-expandable-elements.patch Magnifier (8.79 KB) Marius BALTEANU, 2019-05-29 23:36

0003-Use-icon-icon-classes-for-sort-elements.patch Magnifier (2.54 KB) Marius BALTEANU, 2019-05-29 23:36


Related issues

Related to Redmine - Patch #24313: Use the regular "icon icon-*" classes for all elements wi... Closed
Related to Redmine - Patch #28605: Add the missing icon class to the items with icons from t... Closed
Related to Redmine - Defect #31496: Switch between toggle plus and minus icons for toggle mul... Closed

Associated revisions

Revision 18203
Added by Go MAEDA 5 months ago

Use the regular "icon icon-*" classes for sort-handle (#31433).

Patch by Marius BALTEANU.

Revision 18204
Added by Go MAEDA 5 months ago

Use the regular "icon icon-*" classes for collapsible fields (#31433).

Patch by Marius BALTEANU.

Revision 18208
Added by Go MAEDA 5 months ago

Fix missing icons (#31433).

Patch by Marius BALTEANU.

Revision 18209
Added by Go MAEDA 5 months ago

Use "icon icon-*" classes for expandable elements (#31433).

Patch by Marius BALTEANU.

Revision 18210
Added by Go MAEDA 5 months ago

Use "icon icon-*" classes for sort elements (#31433).

Patch by Marius BALTEANU.

History

#1 Updated by Go MAEDA 5 months ago

  • Target version set to 4.1.0

#2 Updated by Go MAEDA 5 months ago

  • Assignee set to Marius BALTEANU

Could you write the intention of this change?

#3 Updated by Marius BALTEANU 5 months ago

  • Related to Patch #24313: Use the regular "icon icon-*" classes for all elements with icons added

#4 Updated by Marius BALTEANU 5 months ago

  • Related to Patch #28605: Add the missing icon class to the items with icons from the contextual menu added

#5 Updated by Marius BALTEANU 5 months ago

Go MAEDA wrote:

Could you write the intention of this change?

Yes, it is the same as #24313 or #28605.

#6 Updated by Go MAEDA 5 months ago

  • Status changed from New to Closed
  • Assignee changed from Marius BALTEANU to Go MAEDA

Committed the patch. Thanks.

#7 Updated by Marius BALTEANU 5 months ago

  • Status changed from Closed to Reopened
  • Assignee changed from Go MAEDA to Marius BALTEANU

I broke something, I'll add a patch to fix it later.

#9 Updated by Go MAEDA 5 months ago

  • Status changed from Reopened to Closed
  • Assignee changed from Marius BALTEANU to Go MAEDA

Marius BALTEANU wrote:

Here are three more patches:
- 0001-Fix-missing-icons.patch fixes an issue introduced by me (r18204)
- 0002-Use-icon-icon-classes-for-expandable-elements.patch and 0003-Use-icon-icon-classes-for-sort-elements.patch add the "icon icon-*" classes to more elements.

Committed the patches. Thanks.

#10 Updated by Marius BALTEANU 5 months ago

Go MAEDA wrote:

Marius BALTEANU wrote:

Here are three more patches:
- 0001-Fix-missing-icons.patch fixes an issue introduced by me (r18204)
- 0002-Use-icon-icon-classes-for-expandable-elements.patch and 0003-Use-icon-icon-classes-for-sort-elements.patch add the "icon icon-*" classes to more elements.

Committed the patches. Thanks.

Thanks! I'll take a look again to check if it's everything ok.

#11 Updated by Marius BALTEANU 5 months ago

  • Related to Defect #31496: Switch between toggle plus and minus icons for toggle multi select added

#12 Updated by Yuichi HARADA 4 months ago

Collapsed/Expanded of filters and options in "Issues list, Spent time, Gantt, Calendar" do not worked using for IE11.
I think that maybe the toggleClass is the cause.
source:trunk/public/javascripts/application.js@18204#L75

#13 Updated by Go MAEDA 4 months ago

  • Status changed from Closed to Reopened

#14 Updated by Marius BALTEANU 4 months ago

  • Assignee changed from Go MAEDA to Marius BALTEANU

#15 Updated by Marius BALTEANU 3 months ago

  • Status changed from Reopened to Closed
  • Assignee changed from Marius BALTEANU to Go MAEDA

The problem is caused by #3058 and it'll be fixed by the patch from #3058#note-96.

Also available in: Atom PDF