Patch #32013

Rounded corners of the main menu

Added by Antonio McDeal 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:UI
Target version:4.1.0

Description

Most UI elements of Redmine are now rounded, it feels like main menu should too.

rounded-main-menu-corners.patch Magnifier (1021 Bytes) Antonio McDeal, 2019-09-04 18:52

roundedmenu.png (20.4 KB) Antonio McDeal, 2019-09-04 19:33

menu-children-border-radius.png (5.75 KB) Bernhard Rohloff, 2019-09-23 06:51

fixed-menu-children-border-radius.diff Magnifier (1.51 KB) Bernhard Rohloff, 2019-09-23 06:51


Related issues

Related to Redmine - Patch #32015: Rounded corners of "my page" blocks Closed
Related to Redmine - Patch #32014: Rounded corners on table.list elements Closed
Related to Redmine - Patch #32016: Rounded coreners on roadmap's progress bar New
Related to Redmine - Patch #32100: Fixed and added roundiness to the "plus" (+) flyout menu ... New

Associated revisions

Revision 18483
Added by Go MAEDA 3 months ago

Rounded corners of the main menu (#32013).

Patch by Antonio McDeal.

Revision 18543
Added by Go MAEDA 3 months ago

Don't set border-radius for the items in the dropdown menu (#32013).

Patch by Bernhard Rohloff.

History

#1 Updated by Antonio McDeal 3 months ago

#2 Updated by Bernhard Rohloff 3 months ago

  • Related to Patch #32015: Rounded corners of "my page" blocks added

#3 Updated by Bernhard Rohloff 3 months ago

+1 IMHO it looks very nice and polished. It fits nicely into the design of the other tab menus.

#4 Updated by Bernhard Rohloff 3 months ago

  • Related to Patch #32014: Rounded corners on table.list elements added

#5 Updated by Bernhard Rohloff 3 months ago

  • Related to Patch #32016: Rounded coreners on roadmap's progress bar added

#6 Updated by Go MAEDA 3 months ago

  • Target version set to 4.1.0

LGTM. Setting the target version to 4.1.0.

Bernhard Rohloff wrote:

It fits nicely into the design of the other tab menus.

Indeed. Tabs in the project settings page and the administration page already have rounded corner. Tabs in the project menu should have rounded corner as well in order to make the appearance consistent.

#7 Updated by Go MAEDA 3 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you for the nice improvement.

#8 Updated by Bernhard Rohloff 3 months ago

I've discovered a little flaw in the patch. It sets the border radius for the items in the dropdown menu, too. I don't think this was intended by Antonio. Attached is a patch to fix it. It also refactors the previous patch as the border radius can be set in one place.

#9 Updated by Antonio McDeal 3 months ago

Bernhard Rohloff wrote:

I've discovered a little flaw in the patch. It sets the border radius for the items in the dropdown menu, too. I don't think this was intended by Antonio. Attached is a patch to fix it. It also refactors the previous patch as the border radius can be set in one place.

Thanks for the heads up, I already did a fix to this in #32100 but I guess Bernhard's version of this patch here is a bit better, so I will update the second patch in #32100 to bounce off the new circumstances as well :D

I think we should add #32100 as related to this ticket.

#10 Updated by Bernhard Rohloff 3 months ago

  • Related to Patch #32100: Fixed and added roundiness to the "plus" (+) flyout menu and it's child elements added

#11 Updated by Bernhard Rohloff 3 months ago

Antonio McDeal wrote:

... I already did a fix to this in #32100 but I guess Bernhard's version of this patch here is a bit better, so I will update the second patch in #32100 to bounce off the new circumstances as well :D

Oh sorry, I didn't noticed that...

I think we should add #32100 as related to this ticket.

done ;-)

#12 Updated by Antonio McDeal 3 months ago

Go, would it be possible to commit Bernhard's fix? I tested it, works well ;-)

#13 Updated by Go MAEDA 3 months ago

  • Status changed from Reopened to Closed

Bernhard Rohloff wrote:

I've discovered a little flaw in the patch. It sets the border radius for the items in the dropdown menu, too.

Committed the fix fixed-menu-children-border-radius.diff in r18543. Thanks.

Also available in: Atom PDF