Defect #5533

Ellipses at the end of snippets shouldn't be textilized

Added by Felix Schäfer over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:2010-05-16
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:Cant reproduce Affected version:

Description

I just noticed that document snippets textilization on the document overview page (introduced in r3602) also textilizes the ellipse (…) at the end of the snippet. The ellipse should get added to the snippet only after it has been textilized, not the other way round.

test_index_with_long_description.diff Magnifier (2.04 KB) Gregor Schmidt, 2010-06-19 23:48

Associated revisions

Revision 3788
Added by Eric Davis over 8 years ago

Added tests for #5533's behavior.

Contributed by Gregor Schmidt.

History

#1 Updated by Jean-Philippe Lang over 8 years ago

What is the problem with that?

#2 Updated by Felix Schäfer over 8 years ago

Any "unclosed" styling will apply to the ellipses, but they should'nt be styled to make clear that they are not part of the content.

"Just an example" might end as "Just and exam…" right now, or worse could get in the middle of a link and whatnot.

#3 Updated by sdf dfg over 8 years ago

  • Assignee set to Christian Bradley

哈哈,hello

#4 Updated by Felix Schäfer over 8 years ago

  • Assignee deleted (Christian Bradley)

Reverting spam.

#5 Updated by Gregor Schmidt over 8 years ago

The changes in application_helper to truncate the description will only remove full lines. That way only multi-line formattings will be broken. Links and simple text formatting with * and the like will remain intact.

The only multi-line formatting rule I could come up with is pre.

When first applying the textile transformation and truncating afterwards, the three dots will be rendered on a separate line below the pre formatted text. This would not look any better.

If I did not miss an edge case, I would suggest to close this ticket as won't fix.

Attaching a test case, that tests the current behavior.

#6 Updated by Eric Davis over 8 years ago

  • Status changed from New to Closed
  • Target version deleted (0.9.5)
  • Resolution set to Cant reproduce

I agree with Gregor Schmidt, his test case shows that full lines are truncated and then textilized preserving the formatting (visual example: http://rubular.com/r/Xm8AEzMooZ).

If you can provide the exact content that causes an issue, please post it here and we can look into it again.

Also available in: Atom PDF