Defect #5989

Gantt subtasking display broken

Added by Alexey Podlasov over 7 years ago. Updated about 5 years ago.

Status:ClosedStart date:2010-07-29
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:-
Resolution: Affected version:

Description

Gantt does not display subtasks correctly when parent task has greater ID than the child, i.e. when I create parent task after I created the child task, like when I migrate from 0.x which does not support subtasking to 1.0 which supports. The gantt does not display the tree structure correctly

Screenshot.png (15.6 KB) Yuki Kita, 2010-08-01 04:01

Screenshot2.png (14.2 KB) Sepp _, 2010-08-01 15:06

screenshot3.tiff (67.7 KB) Alexey Podlasov, 2010-08-02 04:39


Related issues

Related to Redmine - Patch #5438: Patch repairing rendering of subtasks in gantt diagram Closed 2010-05-04 2010-05-04
Related to Redmine - Patch #7456: Gantt filters New 2011-01-26

History

#1 Updated by Sepp _ over 7 years ago

+1
this should really be corrected in 1.0.1!!!

#2 Updated by Yuki Kita over 7 years ago

I could not reproduced.
Please describe the bug precisely for us to reproduce it.

#3 Updated by Sepp _ over 7 years ago

See the Screenshot!

#4 Updated by Alexey Podlasov over 7 years ago

Yuki Kita wrote:

I could not reproduced.
Please describe the bug precisely for us to reproduce it.

Actually it brakes for me even when parent is created earlier, than a child. Try to create a simple hierarchy with 3-4 different parents each having several children.

P.S. I am using 1.0 r3839

#5 Updated by Alexey Podlasov over 7 years ago

Sequence:
  • Create parents 1, 2 and 3
  • Create child 1.1
  • Check Gantt - OK
  • Create child 1.2
  • Check Gantt - Broken

#7 Updated by Alexey Podlasov over 7 years ago

upgraded to 3902, problem persists

#8 Updated by Daniel Netzer over 7 years ago

Sepp _ wrote:

See the Screenshot!

This happens at my installation too. A ticket has four subtasks in Gantt there are five subtasks AND one of the subtaks is listed as "sub" to another ticket at gantt view? I think the date filter relates to this as setting a filter like: Display all tickets from January and not from the actual month corrects gantt.

Sending screenshots later this day.

#9 Updated by Yuki Kita over 7 years ago

  • Status changed from New to Resolved

Confirmed.

But the bug is duplicate of #5881 or #5194 .
So this issue should be closed.

#10 Updated by Sepp _ over 7 years ago

I don't think that it is a duplicate of either of them!
This is really a bug or defect, no feature!! When you look at Screenshot2.png, there are Issues shown as sub-issue, which just isn't right!
So i think we should reopen this Issue!

#11 Updated by Yuki Kita over 7 years ago

Sepp _ wrote:

This is really a bug or defect, no feature!! When you look at Screenshot2.png, there are Issues shown as sub-issue, which just isn't right!

I understand this is a bug, and should be fixed.
By the way, someone told me that the patch had already been posted in #5438 .
I confirmed tha patch is effective in all of #5881, #5194, #5989 .

So, try the patch of #5438, and report the result.

#12 Updated by Sepp _ over 7 years ago

Works! Thanks!

#13 Updated by Alexey Podlasov over 7 years ago

Is it going to be included into the next stable release, or should I just install the patch?

#14 Updated by Alexey Podlasov over 7 years ago

Patch works fine, thanks!

#15 Updated by Mischa The Evil about 7 years ago

  • Category set to Gantt

#16 Updated by Toshi MARUYAMA about 5 years ago

  • Status changed from Resolved to Closed

Gantt was refactored in #6276.
So, this issue is obsolete.

Also available in: Atom PDF