Defect #6479

Changing tracker type will lose watchers

Added by Kai Hu about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:2010-09-24
Priority:HighDue date:
Assignee:Jean-Baptiste Barth% Done:

100%

Category:Issues
Target version:1.0.2
Resolution:Fixed Affected version:1.0.1

Description

version : 1.0.1

steps to reproduce:
- create a defect ticket
- add a few watchers
- update the ticket to be a feature ticket
- all watchers are gone

Associated revisions

Revision 4181
Added by Jean-Baptiste Barth about 7 years ago

Fixed: don't reset watchers when changing tracker. #6479

History

#1 Updated by Mischa The Evil about 7 years ago

  • Priority changed from Normal to High

The implications of this behaviour results in unexpected loss of watchers...

#2 Updated by Mischa The Evil about 7 years ago

Currently, a workaround to change the tracker without losing all the current watchers is to utilize the issue-move functionality.

#3 Updated by Jean-Baptiste Barth about 7 years ago

  • Status changed from New to Resolved
  • Assignee set to Jean-Baptiste Barth
  • Target version set to 1.1.0
  • % Done changed from 0 to 100
  • Resolution set to Fixed

Fixed in r4181. It may be too late for 1.0.2, so I target it for 1.1.0.

Cause of the bug : it's because changing tracker triggers build_new_issue_from_params method but without params[:issue]['watcher_user_ids'] (when an issue already exists, watchers are managed in the sidebar, not in the main form). It's just a temporary patch, it's not really clean that updating an existing issue triggers new/create actions. So it may need more work later...

#4 Updated by Felix Schäfer about 7 years ago

Jean-Baptiste Barth wrote:

Fixed in r4181. It may be too late for 1.0.2, so I target it for 1.1.0.

It shouldn't wait for 1.1.0, Eric: could you look into adding it to 1.0.2, and if you don't stage it for 1.0.3?

#5 Updated by Eric Davis about 7 years ago

  • Target version changed from 1.1.0 to 1.0.2

Felix:

Agreed, it should be fine for 1.0.2 as long as it merges successfully.

#6 Updated by Eric Davis about 7 years ago

  • Status changed from Resolved to Closed

Merged into 1.0-stable

Also available in: Atom PDF