Defect #6844

Unchecking status filter on the issue list has no effect

Added by Christian Weiske about 7 years ago. Updated over 3 years ago.

Status:ClosedStart date:2010-11-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:1.1.0
Resolution:Fixed Affected version:1.0.3

Description

Unchecking the status filter in the issues list filter does not work.
This happens on http://tt-rss.org/redmine/issues and on this installation here.

Steps to reproduce:
1. http://www.redmine.org/projects/redmine/issues
2. Add a new filter "created by"
3. Add a new filter "created since" 14 days
4. Uncheck the "status" filter
5. Apply
6. Status filter is still active


Related issues

Duplicated by Redmine - Defect #6934: Ticket list: Behaviour with no filter Closed 2010-11-18

Associated revisions

Revision 4387
Added by Jean-Philippe Lang about 7 years ago

Fixed: unchecking status filter on the issue list has no effect (#6844).

History

#1 Updated by Jean-Philippe Lang about 7 years ago

  • Subject changed from Unchecking status filter does not work to Unchecking status filter on the issue list has no effect
  • Status changed from New to Closed
  • Target version set to 1.1.0
  • Resolution set to Fixed

A workaround is to set Status -> all. But it's fixed in r4387.

#2 Updated by Hoc NV over 3 years ago

Hi Jean-Philippe Lang,
i use redmine 2.4 version. So as you memtion above, i still not how to fix it.
i must download all file reference you share and upload to mine right?

Can you help me?

#3 Updated by Go MAEDA over 3 years ago

Hoc NV, I cannot reproduce with Redmine 2.5.2. After clearing the check box "Status" and click "Apply", I can see both open and closed issues. I also tried on www.redmine.org and worked as expected.

Please show the steps to reproduce it on www.redmine.org.

#4 Updated by Hoc NV over 3 years ago

Thanks Go MAEDA reply.
I have just tried and worked as expected.

Thanks so much :)

Also available in: Atom PDF