Defect #6847

Parent priorities not dropping when subtask priorities decreased.

Added by Ewan Makepeace over 8 years ago. Updated about 6 years ago.

Status:ClosedStart date:2010-11-08
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Cant reproduce Affected version:

Description

I have the situation where a parent task has the highest level of priority (emergency in my system) yet none of the subtasks is at that level any more - and I cant manually change it either?

My version is Redmine 1.0.1.devel.4167 (MySQL)

This is the parent task:

These are the subtasks:

If the system was working as I expect, one or both of the mid level parent subtasks would be at emergency, but in fact none of the subtasks is, although it may have been in the past.

parent.jpg (33.1 KB) Ewan Makepeace, 2010-11-08 08:26

subtasks.jpg (67.1 KB) Ewan Makepeace, 2010-11-08 08:26

issue-priorities.png (15.4 KB) Toshi MARUYAMA, 2013-04-11 14:17

Priorities.PNG (7.5 KB) Chris Moser, 2013-04-11 14:26


Related issues

Related to Redmine - Feature #5490: Option for independent subtask priority/start date/due da... Closed 2010-05-10
Related to Redmine - Defect #5880: Only consider open subtasks when computing the priority o... Closed 2010-07-14

History

#1 Updated by Andreas Bosch over 8 years ago

+1 - related to #5490

The current priority handling of parent tasks does not make much sense. Also see this forum post of mine (including an example in the Redmine Demo).

If the parent task should depend on its child tasks at all (see this comment no. 13 for alternatives), I suggest to make its priority equal to the highest priority of all open sub-tasks. Same applies to start/due date and so on.

#2 Updated by Anton Nepomnyaschih over 8 years ago

+1

#3 Updated by txemi M over 8 years ago

+1 - I would like to see this in combination with Andreas Bosch's proposal to let configure per parent inheritance mode.

#4 Updated by Mischa The Evil over 7 years ago

Andreas Bosch wrote:

+1 - related to #5490

The current priority handling of parent tasks does not make much sense. Also see this forum post of mine (including an example in the Redmine Demo).

If the parent task should depend on its child tasks at all (see this comment no. 13 for alternatives), I suggest to make its priority equal to the highest priority of all open sub-tasks. Same applies to start/due date and so on.

Andreas, this whole comment is related to issue #5880 instead of this issue.

#5 Updated by Mischa The Evil over 7 years ago

  • Category set to Issues
  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Ewan Makepeace wrote:

I have the situation where a parent task has the highest level of priority (emergency in my system) yet none of the subtasks is at that level any more - and I cant manually change it either?

Ewan, I have been trying to reproduce this defect on a current source:/trunk@7838 but haven't succeeded. I have tried several setups but at all times the parents' priority matches the highest priority of the available (open and closed, see #5880) subtasks.

Please reopen this issue if you are still able to reproduce the reported defect...

#6 Updated by Chris Moser about 6 years ago

This bug is much worse reproducable with following Redmine-version:

Environment:
Redmine version 2.3.0.stable
Ruby version 1.8.7 (x86_64-linux)
Rails version 3.2.13
Environment production
Database adapter MySQL

What I did:
1) Create task_1 with priority "Normal"
2) Create subtask_1 (parent = task_1) with priority "Critical"

task_1 changes its priority automatically to "Critical"

3) Create subtask_2 (parent = task_1) with priority "Low"

task_1 changes its priority automatically to "Low" though subtask_1 is still priority "Critical"

4) change priority of subtask_2 to "Normal"

task_1 changes its priority automatically to "Normal" thoubh subtask_1 is still priority "Critical"

With this bug the priority-automatisation makes less sense I think??

#7 Updated by Toshi MARUYAMA about 6 years ago

I cannot reproduce on Redmine 2.3.0.
Could you check priority order?

#8 Updated by Toshi MARUYAMA about 6 years ago

  • Status changed from Closed to Reopened

#9 Updated by Toshi MARUYAMA about 6 years ago

  • Status changed from Reopened to Needs feedback

#10 Updated by Chris Moser about 6 years ago

Is the order of the priorities relevant?
I thought Redmine handles only with status_id in this case - therefore the text of the status shouldn't have any influence on the bahaviour of Redmine?

I have attached our priority-configuration ('Niedrig' = 'Low', 'Hoch' = 'High'):

#11 Updated by Toshi MARUYAMA about 6 years ago

Redmine set parent priority with highest priority of children (#443).
source:tags/2.3.0/app/models/issue.rb#L1231

#12 Updated by Chris Moser about 6 years ago

So we have to reorder our priorities in the oposite way we did.
Redmine suppose that the priorities are ordered from low to high - not the opposite way.

Thank you very much! :-)

#13 Updated by Toshi MARUYAMA about 6 years ago

  • Status changed from Needs feedback to Closed

Thank you for your feedback.

#14 Updated by Ewan Makepeace about 6 years ago

I missed the email when this was closed 1 year ago but have retested today and it is working now.

Also available in: Atom PDF