Feature #7599

Allow for multiple useraccounts with same email address

Added by Arno Schoenmakers over 6 years ago. Updated about 5 years ago.

Status:ClosedStart date:2011-02-10
Priority:NormalDue date:
Assignee:Jean-Baptiste Barth% Done:

0%

Category:Administration
Target version:-
Resolution:Wont fix

Description

I am both administrator and worker on several projects. For this I use different user accounts. However, I cannot set the email addresses equal (Redmine does not allow that). Can that be changed? Fine to have a warning if you register as a user with an already used email account, but leave it up to the user to accept that or not. That would solve my problem.


Related issues

Duplicates Redmine - Feature #688: Allow the same email for two accounts Reopened 2008-02-18

History

#1 Updated by Etienne Massip over 6 years ago

  • Category set to Administration

#2 Updated by Felix Schäfer over 6 years ago

Not sure this is feasible as certain parts of Redmine recognize users based on their mail address, especially when Redmine receives mails.

#3 Updated by Jean-Baptiste Barth over 6 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Baptiste Barth
  • Resolution set to Wont fix

Assuming your email address is john@doe.com, maybe you could try to use john+redmineadmin@doe.com for your admin account. Many email providers / MTA accept the + as an easy convention to tag your address, and route every mail to the same final box.

Anyway, as Felix said, I think making email addresses not unique would be a bad idea, so I close this issue. Anyway, I'd be curious to have your feedback about this.

#4 Updated by Arno Schoenmakers over 6 years ago

Hi,

I tried this, but our mail system apparently isn't fooled by this trick... Too bad.

Thanks,

Arno

#5 Updated by Manuel Durán Aguete over 6 years ago

Hello,

I think that allowing duplicate mail address is a good feature, I need it to assign "" to all support team, and when the developer team updates a issue the notification goes to a common mailbox not only to the reporter.

Best Regards.

#6 Updated by Al McNicoll about 5 years ago

Duplicate of #688, where the discussion is more in-depth
(in case anyone else ends up here after Googling as I did)

Also available in: Atom PDF