Defect #7838

Gantt- Issues does not show up in green when start and end date are the same

Added by secu-ring GmbH over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:1.1.3
Resolution:Fixed Affected version:1.1.1

Description

When you have an issue , maybe 4 hours estimated, you pick start and end date for 2011-03-01.
If you close the Ticket it will not show up in green in the gantt chart. When you switch the due date to 2011-03-02 it shows up in green.

maybe you gonna fix this

gantt_progress_calculation_fix.patch Magnifier (854 Bytes) Etienne Massip, 2011-03-12 17:36


Related issues

Related to Redmine - Defect #8233: 100% done 1-day tasks not green on gantt chart Closed

Associated revisions

Revision 5236
Added by Jean-Philippe Lang over 6 years ago

Fixes progress calculation on gantt (#7838).

Contributed by Etienne Massip.

History

#1 Updated by Etienne Massip over 6 years ago

  • Target version set to Candidate for next minor release

Confirmed, although it's not status or estimated time related.

If Due date and Start date are equals and issue is 100% Done then issue line keeps being displayed in grey instead of green.

#2 Updated by Etienne Massip over 6 years ago

  • File gantt_progress_calcultation_fix.patch added

Here's a patch.

#3 Updated by Etienne Massip over 6 years ago

  • File deleted (gantt_progress_calcultation_fix.patch)

#4 Updated by Etienne Massip over 6 years ago

Sorry, missed something.

#5 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from New to Resolved
  • Target version changed from Candidate for next minor release to 1.1.3
  • Resolution set to Fixed

Committed with tests in r5236. I've also fixed a few existing tests that were failing because of the fixed calculation.

#6 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF