Defect #8405

Custom fields - it seems some are omitted.

Added by Ivan Cenov over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-05-19
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Invalid Affected version:

Description

Hello, I saw something suspicious in Redmine trun 5857, concerning the custom fields.

The allowed format for custom fields for Issues, Spent time, Projects, Versions are
Text, Long text, Integer, Float, List, Date, Boolean, User, Version.

The allowed format for custom fields for Users, Groups, Activities (time tracking), Issues priorities, Document categories are
Text, Long text, Integer, Float, List, Date, Boolean

Is this by design or is an omission?


Related issues

Related to Redmine - Feature #2096: Custom fields referencing system tables (users and versio... Closed 2008-10-27

History

#1 Updated by Ivan Cenov over 6 years ago

Configuration:
Redmine trunk 5857
Ruby 1.8.7
Rails 2.3.11
started with "ruby script\server -e production"

Also, Rails 2.3.5 is installed on the machine.

#2 Updated by Etienne Massip over 6 years ago

Refers to JPL note 62 of #2096 (here) and note 66.

#3 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

A User custom field displays a project members list and a Version custom field displays a project versions list. They are project specific and thus only available for things that belong to a project.
This is how it is designed for now.

Also available in: Atom PDF