Defect #9797

Move issue between projects fails if more than one property changed during move

Added by Salim B almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:1.2.2

Description

*Issue opened regarding forum subject : http://www.redmine.org/boards/2/topics/27807

Issues can't be moved to another project if any other property is changed with (tracker, assignee etc.)
We're only too to reproduce this error from now, and it seems to be related to our environments : we both migrated from 0.9.x redmine version.

- In project created after the redmine migration, I don't meet the issue.
- Actual production is in 1.1.2, but I can reproduce the error when upgrading to 1.2.2.

Feel free to ask me some testing or more logs, as soon as you tell how to get those :)

------------------------
Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.4.2
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Edge Rails revision unknown
Application root /opt/redmine-1.1.2
Environment production
Database adapter mysql
Database schema version 20101114115359
[root@localhost redmine-1.1.2]#

DEBUG-Logs.txt Magnifier - Logs (Debug), starting from click on 'Move" (52.7 KB) Salim B, 2011-12-14 17:31

Capture.PNG - Screenshot (11.8 KB) Salim B, 2011-12-14 17:31


Related issues

Duplicates Redmine - Defect #6859: Moving issues to a tracker with different custom fields s... Closed 2010-11-09

History

#1 Updated by Etienne Massip almost 6 years ago

  • Category set to Issues

#2 Updated by Salim B almost 6 years ago

Logs and screenshot attached.

#3 Updated by Etienne Massip almost 6 years ago

  • Affected version (unused) set to 1.2.2
  • Affected version set to 1.2.2

#4 Updated by Stefan Halter almost 6 years ago

I can report similar behavior in our system. It works fine with newly created projects, but does not work with "old" projects. We recently upgraded Redmine from 0.9 to. 1.2.2. Some days ago we upgraded to latest stable 1.3.

  • if I copy an issue from (1.3) project A to a (created under 0.9) project B = failure
  • if I copy an issue from (created under 0.9) project B to a (1.3) project A = works
  • if I copy an isuse from (1.3) project A to a (created under 1.2.2) project B = works

In each case I changed tracker and project. We really need to have this working!

#5 Updated by Etienne Massip almost 6 years ago

Could that be related to (mandatory?) custom fields used in each project?

#6 Updated by Stefan Halter almost 6 years ago

Good hint! It works perfect!

#7 Updated by Salim B almost 6 years ago

Stefan, what did you do exactly ?
removed custom fields or made those non mandatory ?

#8 Updated by Stefan Halter almost 6 years ago

I had one mandatory custom field in "Project B". After deselecting that "mandatory" box both projects (from project A to project B) have equal requirements.

#9 Updated by Salim B almost 6 years ago

OK, same result here.
I managed to make it work by making 3 custom fields non-mandatory

#10 Updated by Etienne Massip almost 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as duplicate of #6859.

Also available in: Atom PDF