Defect #9824

Visual merge/branch history words are cut off

Added by Denny Schäfer almost 6 years ago. Updated about 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Wont fix Affected version:1.3.0

Description

In the visual merge/branch history the word are cut off. For example the word master is cut off after m.

error.png (22.9 KB) Denny Schäfer, 2011-12-16 10:08

Screen Shot 2011-12-21 at 9.42.01 PM.png (49.1 KB) Morgan Jones, 2011-12-22 05:44

NoBranch.PNG (14.8 KB) Pedro Alexandre Pacheco Cipriano, 2012-03-09 10:47

OneBranch.PNG (16 KB) Pedro Alexandre Pacheco Cipriano, 2012-03-09 10:47

fix-revisiongraph-width.patch Magnifier - Patch to fix revision graph width (652 Bytes) Daniel Ritz, 2012-03-14 12:12


Related issues

Related to Redmine - Feature #5501: Git: Mercurial: Adding visual merge/branch history to rep... Closed 2010-05-11
Duplicated by Redmine - Defect #9940: Branch names are truncated Closed
Duplicated by Redmine - Defect #10049: Repository view is not right Closed
Duplicated by Redmine - Defect #10144: repository view bug Closed
Duplicated by Redmine - Defect #10542: Repository style bug Closed

History

#1 Updated by Denny Schäfer almost 6 years ago

The error is in file revision_graph.js line 31.In my case var cw is every 40.

#2 Updated by Etienne Massip almost 6 years ago

  • Category set to SCM

#3 Updated by Etienne Massip almost 6 years ago

  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

#4 Updated by Alex Pogodin almost 6 years ago

Had the same effect until I refreshed my changesets. Try to remove and then readd the repo, worked for me

#5 Updated by Morgan Jones almost 6 years ago

Alex Pogodin wrote:

Had the same effect until I refreshed my changesets. Try to remove and then readd the repo, worked for me

I did and the result was the same. Shouldn't it look like more of a revision graph and less of a bullet pointed list? (tested on Mac Chrome 17.0.963.12)

I expanded the X spacing in the JS and still get a similar thing.

Screenshot: http://d.pr/EhJu

#6 Updated by Morgan Jones almost 6 years ago

That screenshot link is invalid. Screenshot is attached.

#7 Updated by Il'ya Shakitko over 5 years ago

May be i will help. This bug is only for old commits (before redmine update). After update the branch graph is ok.

UPD. I wrong.

#8 Updated by Pedro Alexandre Pacheco Cipriano over 5 years ago

Denny Schäfer wrote:

In the visual merge/branch history the word are cut off. For example the word master is cut off after m.

I can reproduce the behaviour quite easily. It seems that when there is not enough branches to increase the horizontal width the words are cut off.

#9 Updated by Daniel Ritz over 5 years ago

Attached a fix that works fine for me. It changes the width dynamically if there's not enough room to draw the tag names. Against 1.3.2.

#10 Updated by Etienne Massip over 5 years ago

BTW, the way the graph is integrated into the revision list has been changed with 1.4.0.

We removed the head revision branch names since they will necessarily be cut off and display them on revision dot hover.

There is still room for improvements, though.

#11 Updated by Daniel Ritz over 5 years ago

Etienne Massip wrote:

BTW, the way the graph is integrated into the revision list has been changed with 1.4.0.
We removed the head revision branch names since they will necessarily be cut off and display them on revision dot hover.

Yeah I know, but I needed a quick fix for the stable version, so I thought I share it :)

#12 Updated by Denny Schäfer over 5 years ago

Thanks for patching this bug

Daniel Ritz wrote:

Attached a fix that works fine for me. It changes the width dynamically if there's not enough room to draw the tag names. Against 1.3.2.

#13 Updated by Denny Schäfer about 5 years ago

It looks like that the defect go away (i can't reproduce it with the last 1.4 version). Could anyone close the ticket?

#14 Updated by Etienne Massip about 5 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Wont fix

Fixed when changed the way the visual tree is displayed for 1.4.0.

#15 Updated by Etienne Massip about 5 years ago

  • Target version deleted (Candidate for next minor release)

Also available in: Atom PDF