Redmine won't start after crash

Added by Bill L over 11 years ago

Hi Guys, I've been using redmine for two years, the application used to run very well, I installed it on CentOS 5.5 virtual linux box, recently I upgrade to the newest version v 1.1.0 and all functions are working fine.

This morning our VM host server has some problem, we lost contact with it, so we have to reboot it, after the reboot, redmine virtual box is bootup well, but redmine won't start anymore, the detail is after I input the command
"ruby script/server -e production -d"
in redmine 1.1.0 installation directory, I can see message :
"=> Booting WEBrick
=> Rails 2.3.5 application starting on http://0.0.0.0:3000",
and then I beleive the server quit almost immediately because after I run "ps -aux" command after "ruby script/server -e production -d", I can see
"root 5671 91.0 4.1 25844 21476 ? R 13:51 0:00 ruby script/server -e production -d",
but after two seconds later, I could see it anymore if I run "ps -aux" again.

I guess the crash this morning caused this or yesterday I installed webmin caused this, but I could not find any useful information from log directory of redmine, or system log records, is there anywhere I can find failed information?

Replies (9)

RE: Redmine won't start after crash - Added by Bill L over 11 years ago

Bill LIU wrote:

but after two seconds later, I could see it anymore if I run "ps -aux" again.

sorry, should be "I could not see it anymore if I run "ps -aux" again."

RE: Redmine won't start after crash - Added by Felix Schäfer over 11 years ago

Start the server with just ruby script/server -e production, that way webrick will stick to your console instead of daemonizing, and you will probably get more info. Be aware that webrick is generally a subpar if not even bad choice for a production server, you should rather use passenger or mongrel.

RE: Redmine won't start after crash - Added by Bill L over 11 years ago

Thanks for your reply, I would like to use passenger or mongrel, but where can I find the document how to do it?

By using your command, here is error message :

/var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:426:in `load_missing_constant': Expected /var/www/html/redmine-1.1.0/app/models/user.rb to define User (LoadError)
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:80:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:92:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:437:in `load_missing_constant'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:96:in `const_missing'
        from /var/www/html/redmine-1.1.0/app/models/project.rb:30
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:265:in `require_or_load'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:425:in `load_missing_constant'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:80:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:92:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:437:in `load_missing_constant'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:96:in `const_missing'
        from /var/www/html/redmine-1.1.0/app/models/principal.rb:22
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:265:in `require_or_load'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:425:in `load_missing_constant'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:80:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:92:in `const_missing'
        from /var/www/html/redmine-1.1.0/app/models/user.rb:20
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:265:in `require_or_load'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:425:in `load_missing_constant'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:80:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:92:in `const_missing'
        from /var/www/html/redmine-1.1.0/vendor/plugins/local_avatars/lib/users_avatar_patch.rb:17
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
        from /var/www/html/redmine-1.1.0/vendor/plugins/local_avatars/init.rb:3:in `evaluate_init_rb'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/rails/plugin.rb:158:in `evaluate_init_rb'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/rails/plugin.rb:154:in `evaluate_init_rb'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/rails/plugin.rb:48:in `load'
        from /var/www/html/redmine-1.1.0/config/../vendor/plugins/engines/lib/engines/plugin.rb:44:in `load'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:38:in `load_plugins'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:37:in `each'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:37:in `load_plugins'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/initializer.rb:369:in `load_plugins'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/initializer.rb:165:in `process'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
        from /var/www/html/redmine-1.1.0/config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
        from /var/www/html/redmine-1.1.0/config/environment.rb:20
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
        from /var/www/html/redmine-1.1.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
        from /var/www/html/redmine-1.1.0/vendor/rails/railties/lib/commands/server.rb:84
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3

not really understand the error message means.

RE: Redmine won't start after crash - Added by Felix Schäfer over 11 years ago

Bill LIU wrote:

Thanks for your reply, I would like to use passenger or mongrel, but where can I find the document how to do it?

I think there are some tutorials here on redmine.org in the wiki, else try to look for a tutorial on how to install either one on the linux distribution you are using.

By using your command, here is error message :

[...]

not really understand the error message means.

You seem to have the local_avatars plugin installed, it is either not up-to-date or not compatible with redmine 1.1.0 at the moment. Please contact the plugin author for more help.

RE: Redmine won't start after crash - Added by Bill L over 11 years ago

Searched on Google and then installed passenger, passenger give almost same error message, there must be some files missing, I try to remove that plugin first to see how things going.

RE: Redmine won't start after crash - Added by Felix Schäfer over 11 years ago

Bill L wrote:

I try to remove that plugin first to see how things going.

Yes, changing the way you serve redmine doesn't remove the problem. As I said, the problem you have is the local_avatars plugin.

RE: Redmine won't start after crash - Added by Bill L over 11 years ago

remove the local_avatars plugin and then got everything back, thanks for your help.

RE: Redmine won't start after crash - Added by Andrew Sinclair over 11 years ago

I think I have the same issue you had with the local_avatars plugin. How did you remove it?

RE: Redmine won't start after crash - Added by Bill L over 11 years ago

get into plugin folder and use "rm -d -f" command to remove it, after that I re-initialized plugins and then restart the redmine.

(1-9/9)