Project

General

Profile

Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x?

Added by Tony Wagner over 11 years ago

We just installed Redmine 2, but as we are browsing for plugins to install, we notice that virtually every plugin we want to use is still only compatible with Redmine 1.x.

Should we just downgrade? Is the Redmine community going to stick with version 1.x for the foreseeable future? We don't want to be stuck with a less-robust product while waiting for the rest of the community to upgrade to version 2.

We've already started creating some projects, wiki entries, etc., so it will probably be a bit of a hassle, unless anyone has any tips. We're fairly early in the process so we could always spend a little while copying and pasting too, if it comes to that.


Replies (7)

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by William Roush over 11 years ago

What plugins do you have that aren't 2.0 compatible? Myself and many in the community have been porting "dead" projects to 2.0.

2.0 is the future, 1.x will die with 1.4 if I'm not mistaken.

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by Tony Wagner over 11 years ago

Just looking at the plugins directory here:

http://www.redmine.org/plugins

Unless there is somewhere else I should be looking? (It would be great if plugins could be sorted by what version of Redmine they are compatible with.)

I don't doubt that 2.0 is the future, but almost everything listed there is 1.x compatible only. Contacts, Google Apps login, Lightbox, Wiki HTML, and the list goes on. Not all of these are critical for us, of course, but it feels like we might be paying an early adopter penalty by using 2.0 right now. Are most 1.x plugin authors even interested in upgrading to 2.0 yet, or are a lot of people content to continue using 1.x for the next couple years? If I had a stable, customized 1.x server I don't think I'd bother upgrading for awhile.

Like I said, we're just getting started. I was just thinking it might be a better approach to start with 1.4 and wait for 2.0 to catch up?

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by William Roush over 11 years ago

Tony Wagner wrote:

Just looking at the plugins directory here:

http://www.redmine.org/plugins

Unless there is somewhere else I should be looking? (It would be great if plugins could be sorted by what version of Redmine they are compatible with.)

I don't doubt that 2.0 is the future, but almost everything listed there is 1.x compatible only. Contacts, Google Apps login, Lightbox, Wiki HTML, and the list goes on. Not all of these are critical for us, of course, but it feels like we might be paying an early adopter penalty by using 2.0 right now. Are most 1.x plugin authors even interested in upgrading to 2.0 yet, or are a lot of people content to continue using 1.x for the next couple years? If I had a stable, customized 1.x server I don't think I'd bother upgrading for awhile.

Like I said, we're just getting started. I was just thinking it might be a better approach to start with 1.4 and wait for 2.0 to catch up?

You'll have to check project pages sometimes or forks of the original project, for example, lightbox:

http://www.redmine.org/plugins/redmine_lightbox

Only Redmine 1.2?

https://github.com/zipme/redmine_lightbox

Nope, Redmine 2.0 support.

Pretty sure Redmine CRM (AKA: "Contacts") supports it (commercial product and all).

Google Apps support has a couple forks:

https://github.com/waj/redmine_google_apps/network

Mainly: the plugin pages are just poorly maintained, so your mileage will vary (especially being as if I fork a project, I cannot update it's plugin record).

You may just want to stick with 1.4, but I still wouldn't get attached to plugins that outright aren't being maintained, like Wiki HTML, which will probably never see the light of day with 2.0 at this rate.

1.4 -> 2.0 compatibility is pretty straightforward though.

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by Terence Mill over 11 years ago

you have to check the github issue tracker, many of the plugins have an 2.0 branch of fork.
Lightbox trunk is 2.0 compatible and 1.3 also

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by Jan Niggemann (redmine.org team member) over 11 years ago

Is someone working on improving the plugin ecosystem? It's current state makes it somewhat chilling, I'm sure some people that, if told to "search github for a fork", discard redmine as a solution right away rather than give it a chance :-/

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by William Roush over 11 years ago

J N wrote:

Is someone working on improving the plugin ecosystem? It's current state makes it somewhat chilling, I'm sure some people that, if told to "search github for a fork", discard redmine as a solution right away rather than give it a chance :-/

Yeah we should be able to submit patches and such to already available plugins or something...

RE: Redmine 1.x vs 2 -- plugin compatibility? Downgrade to 1.x? - Added by Martín Palacio P about 11 years ago

I'm exactly on the same boat. I'm really interested in:

  • redmine-openid-selector
  • openid-fix

I have created two repositories in github (mppfiles) and successfully migrated the first one to work with redmine 2.2.0. As of now I'm struggling with openid-fix.

Any kind of help is very appreciated!

    (1-7/7)