Redmine 0.8 in Dreamhost

Added by Marco Catunda over 13 years ago

I've just updated redmine from 0.7 to 0.8, with no success. I'm not rails expert, so I need help! :(

I updated rails using this command

gem install --version 2.1.2

Added this line at the top of config/environment.rb

ENV['GEM_PATH'] = '/home/<local>/.gems:/usr/lib/ruby/gems/1.8'

Upgraded redmine throught svn update

The passenger complains rails 2.1.2 version, It haven't seen the new
version that I had upgraded by gem install as described above,
therefore I freeze the rails with the command below:

rake rails:freeze:edge TAG=rel_2-1-2

Now, the passenger display the following error:

uninitialized constant ActionController::Session::PStore

I'm completely freeze, I have no idea what I have to do...
Does anyone could help me? Any tips?

--
Marco Catunda

Replies (5)

RE: Redmine 0.8 in Dreamhost - Added by Ankur Naik over 13 years ago

Hmm, in my config/environment.rb, I don't have the ENV['GEM_PATH'] line, but I do have the following:

RAILS_GEM_VERSION = '2.1.1' unless defined? RAILS_GEM_VERSION

2.1.2 does not seem to be available any longer (gem list shows 2.2.2, 2.1.1, and 2.1.0), and according to this DreamHost wiki page "Passenger will not use the 'rails' installation in your local gems repository".

So I think if you remove your ENV['GEM_PATH'] setting and add the RAILS_GEM_VERSION line, it should work. Note: I've only tried it with 2.1.1.

RE: Redmine 0.8 in Dreamhost - Added by Kuba Zwolinski over 13 years ago

I have the same problem as Marco, after commenting out session line in config/environment.rb I got different error

uninitialized constant ActionController::AbstractRequest

Then I tried Ankur's way - and got another error:

RubyGem version error: rack(0.3.0 not >= 0.9.0)

I have installed:
Ruby 1.8.6 (2008-08-11 patchlevel 287) [i686-linux]
Rails 2.1.2 (custom installation)
Rack 0.9.0 (that is weird)

What is also interesting, my Redmine 0.7 on other domain works fine with the same settings

RE: Redmine 0.8 in Dreamhost - Added by Marco Catunda over 13 years ago

@Ankur Naik

I changed this line

RAILS_GEM_VERSION = '2.1.1' unless defined? RAILS_GEM_VERSION

The system's error go away. Thanks!!

RE: Redmine 0.8 in Dreamhost - Added by Enderson Maia over 13 years ago

I've done everything you said before, but still have the error.

uninitialized constant ActionController::AbstractRequest

Changed RAILS_GEM_VERSION 2.1.1, 2.1.2, 2.2.2 and still have the error.

The error changes if I switch the lines config.action_controller.{session,session_store}

...

RE: Redmine 0.8 in Dreamhost - Added by Enderson Maia over 13 years ago

Enderson Maia wrote:

I've done everything you said before, but still have the error.

uninitialized constant ActionController::AbstractRequest

Changed RAILS_GEM_VERSION 2.1.1, 2.1.2, 2.2.2 and still have the error.

The error changes if I switch the lines config.action_controller.{session,session_store}

...

I did a rake rails:unfreeze before changing RAILS_GEM_VERSION to 2.1.1 and it works now.

:)

(1-5/5)