Redmine on Synology NAS server

Added by Maxim Krušina over 11 years ago

Hi There, I've a complicated idea: I would like to try to install Redmine n my home NAS server - Synology. By quick research I found, that some folks intalled rubby on Synology, but probably not Redmine. Anybody already tried or interested? ;)

Replies (3)

RE: Redmine on Synology NAS server - Added by Renzo Meister over 10 years ago


I've tried to install Redmine on Synology DS109 but it doesn't work because the existing ruby package has version 1.9.1, which isn't supported by Redmine. Then I've tried to compile the Ruby 1.8.7 but there is a bug when "make" it. I had always the error "clock_gettime undefined reference" so I couldn't install it on synology :-s.

Is there a Linux guru who can help me? It would be very very nice because I'd like to use Redmine on my Synology!

Best Regards

Renzo Meister

RE: Redmine on Synology NAS server - Added by quenenni frutti over 10 years ago


I tried too to compile ruby 1.8.7 and have the same problem as you.

So, I was wondering if anyone knows when redmine will support ruby 1.9 branch?
It's already 14 months that the ruby 1.8.7 support in redmine was added, so maybe.. maybe..

That'll be great as ruby 1.9.1 can be easily installed on a NAS server, and so hopefully redmine (that is a really great tool)


RE: Redmine on Synology NAS server - Added by Kalun Wong over 7 years ago


I have the same problem too, may I have any update on this issue?