Edit issue shows wrong properties?

Added by Ed Bras about 8 years ago

When editing an issue, I notice the following problem:
+ When I create a new issue, the issue status is set to "Solved" instead of "New" like before.
+ When I edit an existing issue, it shows the wrong issue properties: other project (first one ever created), "Solved" always as status; no target version anymore, 100% completed (was 0%), etc...
I then have to change everything to be able to update the issue :(

The problem might be there already some time, but I worked a long time on the project that doesn't shows this problem, and is the project that is chosen when editing an issue of another project.

I just updated to 2.5.1, tried the above also for a new project, went to the settings, but can't seem to solve it.
Please some advice on how to solve this?
(I am using postgres 9.1 as db)

- Ed

Replies (13)

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

Anybody any idea how to solve this?
It's very annoying :(

Every time I update an issue, many properties are set wrong like Feature is changes, status is always "Solved", Progress is always 100%, Assigned to wrong project, etc..
I then have to change all these back, when simply adding some info in the issue. I's easy to not update all properties as I/we often don't remember exactly how they where that results in bugs in an issue...

Is this maybe a bug?

I have admin rights, but the problem also occurs when I added a brand new user that is a member of 2 projects. Only the Project assigment property isn't visible in that case (such that not specific project properties are shown), but it sill change things like feature-> bug, progress 0% -> 100%, status to solved...
I have attached an issue edit action of this new user. As you see in the edit mode down in the screen, the properties have changed...why?

I have gone through all settings several times, but can't find any issues there.

What is the expected behavior?

Capture.PNG - Edit action. (51.2 KB)

RE: Edit issue shows wrong properties? - Added by Anonymous about 8 years ago

Hi Ed,

it's very difficult to give advice on this. Workflow depends on user's role and can be defined very granular. Defaults can be set depending on category. Also if a Ticket is subticket of another, properties of the master ticket are no more independent and depend on subticket's status. Progress calculation can be done based on hrs spent/estimated or on status - check this.

My other recommendation: have a close look at your workflow definition (for the new user's role) and check for allowed transitions. If nothing helps, activate all possible status-transitions.

cheers

Alex

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

Thanks.
I just checked all workflow transitions for the developer and manager role which I both have (i also have admin rights).
But still, when editing an existing Feature with the "new" status, it does the same, shows another project as project, and changes the Tracker to "Bug", etc...

But still, in my case with admin rights, why does it show another project in the project field (and as such other fields) when editing a feature issue :(...?
That doesn't sound like a workflow issue?

RE: Edit issue shows wrong properties? - Added by Anonymous about 8 years ago

You are right - this sounds very strange. Next step could be to check datbase-IDs of projects (is there a duplicate ID for projects?). Easiest was is to use phpmyadmin and inspect tables. But if so, how to fix this I have no idea.

Alex

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

I just looked in the projects table, and the identifiers are all different, so that look good.
I scanned the tables, but don't really know where to look at.

BTW: I am running Redmine against Postgres 9.0.

Let's try to pin point the problem:
Let's start with the problem:
"it's shows another Project as Project property when editing an issue"
What should be the cause and where/how is this determined?

Any advice, please let me know?

RE: Edit issue shows wrong properties? - Added by @ go2null about 8 years ago

For done , check in administration /settings / item tracking and I'm sure that calculate... is set to status. As the status is being set to Solved. ( and I'm sure that * administration /issue statuses* has it's Done as 100%), that is why.

Now the question is why is the status being set to Solved.

And then trace back up to tracker enabled fields.

Check as well that at least one role has access to do what you want to do. As even Admin cannot do what is not defined in a role. (at least that is my interpretations - that Admin inherits the aggregate of all roles and permissions and workflow.)

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

Thanks for you feedback.
Let take one step at a time please, you are going a bit too fast ;)..

For done , check in administration /settings / item tracking and I'm sure that calculate... is set to status

It's set to "Use the issue field", not status, see screenshot.

I'm sure that * administration /issue statuses* has it's Done as 100%

Sorry, I don't really understand what you mean here, please explain.

And then trace back up to tracker enabled fields

Feature and Bug have both all fields enabled.

Check as well that at least one role has access to do what you want to do

The user (me) that has Admin rights, has both the Manager and Developer role, and I think both these roles can do what I want.
I looked at the permissions of these roles, and it all looks good (see attachment). I can't even remember even changing this.
I installed Redmine about 2 years ago and I am the only one that manage it, and I think that most settings are default (expect the ones that I changed trying to solve this issue).

Any more ideas where to look?
Is it possible to restore to default/factory settings without losing stuff like users/issues ?
Thanks all for the ideas

Capture.PNG - Admin Issue tracking (33.6 KB)

Capture.PNG - Feature enabled field (8.56 KB)

Capture.PNG - Bug enabled field (8.41 KB)

Capture.PNG - Manager permissions. (46.1 KB)

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

Attached also the Developer permissions

Capture.PNG - Developer permissions (46.2 KB)

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

Any body any advice on this?
It's very annoying to always having to change all field values back to their actual value when editing an issue :(...
Just been through all settings again and again, and really have no clue... :(

RE: Edit issue shows wrong properties? - Added by Michal Seliga about 8 years ago

I've similar issue after update from 2.4.x to 2.5.2 it always change status to "New" in issue edit form, when I try change status via SVN revision message or right click menu in search result it works well :-(

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

I played some more with it as I still got the same issue and I think it's a bug. No setting I tried (and dummy users/projects) same to be able to solve this.

I removed the Admin rights from myself, and at least it doesn't show my now the wrong project as property, but still it will all of a sudden change "Feature" to "Bug", "New" to "Resolved".... For now reason at all.

RE: Edit issue shows wrong properties? - Added by Michal Seliga about 8 years ago

Michal Seliga wrote:

I've similar issue after update from 2.4.x to 2.5.2 it always change status to "New" in issue edit form, when I try change status via SVN revision message or right click menu in search result it works well :-(

My issue was one of installed plugins called "redmine_change_issue_author". Once plugin has been removed it works as expected.

RE: Edit issue shows wrong properties? - Added by Ed Bras about 8 years ago

Thanks Michal.
Your are lucky, that it's solved in your case. I don't have any plugin installed, so it must some other issue...

(1-13/13)