Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ...

Added by Reiner Lichtenberger over 2 years ago

Hi,
I configured configuration.yml as followed:

email_delivery:
delivery_method: :smtp
smtp_settings:
address: ""
port: 465
authentication: :login
domain: 'xxxx.xx'
user_name: ''
password: 'xxxx'

and it shows:

Email delivery is not configured, and notifications are disabled.
Configure your SMTP server in config/configuration.yml and restart the application to enable them.

any idea whats wrong?
thx

Replies (9)

RE: Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ... - Added by Go MAEDA over 2 years ago

Do you use tabs in configuration.yml? If so, please use two spaces instead of a tab to indent.

An indent in YAML must be two spaces. Tabs are not allowed.

RE: Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ... - Added by Go MAEDA over 2 years ago

Could you attach the entire configuration.yml with sensitive information masked?

RE: Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ... - Added by Go MAEDA over 2 years ago

I had to fix the indent. But "Email notifications" tab is displayed with the fixed config.

--- configuration_forum.yml     2020-05-07 18:09:39.000000000 +0900
+++ configuration.yml   2020-05-07 17:23:40.000000000 +0900
@@ -28,11 +28,11 @@
    delivery_method: :smtp
    smtp_settings:
      address: "is@lhxxx.de" 
-      port: 465
-      authentication: :login
-      domain: 'lhxxx.de'
-      user_name: 'is@lhxxx.de'
-      password: 'huhu!'
+     port: 465
+     authentication: :login
+     domain: 'lhxxx.de'
+     user_name: 'is@lhxxx.de'
+     password: 'huhu!'
   #
   # ==== SMTP server at example.com using PLAIN authentication
   #

RE: Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ... - Added by Reiner Lichtenberger over 2 years ago

Coool THX - config works, but when I send a test mail it says:
"An error occurred while sending mail (getaddrinfo: Name or service not known)"
-> any idea? thx

RE: Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ... - Added by Go MAEDA over 2 years ago

Your configuration seems the address setting is wrong. This must be the hostname of your outgoing SMTP server but your email address.

RE: Email delivery is not configured, and notifications are disabled. Configure your SMTP server in config/configuration.yml ... - Added by Reiner Lichtenberger over 2 years ago

hi, thx, but nope - I changed, but it sill exists.
thats the config:

email_delivery:
delivery_method: :smtp
smtp_settings:
address: "ghgh.de"
port: 465
authentication: :login
domain: 'ghgh.de'
user_name: ''
password: 'xxxxx'

thx for help

(1-9/9)