cannot run redmine

Added by Pakcik Kantin about 13 years ago

Guys,
I'm totally new to redmine and ruby. Basically i can run simple ruby app
when i tried to run
ruby script/server on my redmine directory errors occured

/opt/ruby/redmine/vendor/rails/railties/lib/initializer.rb:1:in `require': no such file to load -- logger (LoadError)
        from /opt/ruby/redmine/vendor/rails/railties/lib/initializer.rb:1
        from ./script/../config/boot.rb:45:in `require'
        from ./script/../config/boot.rb:45:in `load_initializer'
        from ./script/../config/boot.rb:38:in `run'
        from ./script/../config/boot.rb:11:in `boot!'
        from ./script/../config/boot.rb:109
        from script/server:2:in `require'
        from script/server:2

Can any one give ideas on how to solve this .Your help is much appreciated

Replies (2)

RE: cannot run redmine - Added by Pakcik Kantin about 13 years ago

Now i receive this error

/opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require': no such file to load -- test/unit/error (MissingSourceFile)
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `block in require'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in `new_constants_in'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/deprecation.rb:204:in `<top (required)>'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `block in require'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in `new_constants_in'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /opt/ruby/redmine/vendor/rails/activesupport/lib/active_support.rb:40:in `<top (required)>'
from /opt/ruby/redmine/vendor/rails/railties/lib/commands/server.rb:1:in `require'
from /opt/ruby/redmine/vendor/rails/railties/lib/commands/server.rb:1:in `<top (required)>'
from script/server:3:in `require'
from script/server:3:in `<main>'

RE: cannot run redmine - Added by Pakcik Kantin about 13 years ago

Sorry guys just found out, i have installed Ruby-1.9.1.. i've read somewhere only version Ruby 1.8.6 and 1.8.7 supported for redmine.
Tq

(1-2/2)