missing gems during installation

Added by jnns . over 10 years ago

Hi,

I'm trying to install redmine-0.9 and encountered the following message:

$ RAILS_ENV=test_sqlite3 rake db:migrate
(in ~/redmine-0.9)
Missing these required gems:
  thoughtbot-shoulda  
  nofxx-object_daddy  
  mocha  

You're running:
  ruby 1.8.7.249 at /usr/bin/ruby1.8
  rubygems 1.3.5 at ~/gems, /var/lib/gems/1.8

Run `rake gems:install` to install the missing gems.

As suggested, I tried running rake gems:install but that didn't help. Though gem install mocha works I still have no idea how to get the other two packages installed.

Do you have any idea? Thanks in advance

Replies (9)

RE: missing gems during installation - Added by jnns . over 10 years ago

The only one that was a bit tricky to install was thoughtbot-shoulda but even that wasn't really tricky after reading http://wiki.github.com/thoughtbot/shoulda/installation

sudo gem install thoughtbot-shoulda --source=http://gems.github.com

That's it!

RE: missing gems during installation - Added by Henning Sprang over 10 years ago

and where did you find the nofxx-object_daddy stuff?

RE: missing gems during installation - Added by Henning Sprang over 10 years ago

ah, nofxx-object_daddy can be installed the same way...

In any case, these things should really be added to the INSTALL howto file in the distribution zip...

RE: missing gems during installation - Added by Jean-Philippe Lang over 10 years ago

Read doc/RUNNING_TESTS:

rake gems:install RAILS_ENV="test"

RE: missing gems during installation - Added by Henning Sprang over 10 years ago

Jean-Philippe, are you sure that the mentioned gems are really only required for testing?

In my case, I didn't want to run tests, I just wanted to run redmine with a local sqlite for evaluation purposes, so I changed the database settings for the production environment and wanted to run ./scripts/server and the db migration/setup stuff.

RE: missing gems during installation - Added by jnns . over 10 years ago

Same scenario here. I also just wanted to run the sqlite environment and it didn't work out without said gems.

RE: missing gems during installation - Added by Henning Sprang over 10 years ago

@jnns jnns:

As far as I understood in the meantime, you should create an environment that's name doesn't start with "test", or change the production or dev environment to use sqlite, then it should work.

RE: missing gems during installation - Added by jnns . over 10 years ago

Ok, that must've slipped my attention. Thanks for clarifying that!

RE: missing gems during installation - Added by Anatoly Moschenko over 10 years ago

My

rake gems RAILS_ENV=test

returned
(in /home/anatan/redmine/redmine-0.9.3)
 - [F] rubytree
    - [ ] hoe >= 1.3.0
 - [I] thoughtbot-shoulda
 - [I] edavis10-object_daddy
 - [I] mocha
    - [I] rake

I = Installed
F = Frozen
R = Framework (loaded before rails starts)

Ok, I installed all packeges and replaced line
config.gem "nofxx-object_daddy", :lib => "object_daddy", :source => "http://gems.github.com" 

to
config.gem "edavis10-object_daddy", :lib => "object_daddy", :source => "http://gems.github.com" 

in '/config/environments/test_sqlite3.rb'
and run
rake db:migrate RAILS_ENV="test_sqlite3" 
again. And it works.

(1-9/9)