Problem with db

Added by Alexey Popov about 10 years ago

Debian... i use postgres

# gem --version
1.3.5
# rails --version
Rails 2.3.5
# ruby --version
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

Then...

# RAILS_ENV="production" rake db:migrate
(in /var/www/area51.leemocms.com/htdocs)
rake aborted!
syntax error on line 5, col 27: `'

(See full trace by running task with --trace)

So... what problem?

Replies (7)

RE: Problem with db - Added by Alexey Popov about 10 years ago

Wow!!! I read [[http://www.redmine.org/boards/2/topics/667]]... so

# RAILS_ENV="production" script/about
/usr/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 5, col 27: `butes_before_type_cast' (ArgumentError)
        from /usr/lib/ruby/1.8/yaml.rb:133:in `load'
        from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:902:in `database_configuration'
        from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:437:in `initialize_database'
        from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:141:in `process'
        from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `send'
        from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `run'
        from /var/www/area51.leemocms.com/htdocs/config/environment.rb:20
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/about.rb:1
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/about:4

RE: Problem with db - Added by Felix Schäfer about 10 years ago

The configuration for your production database is incorrect.

RE: Problem with db - Added by Alexey Popov about 10 years ago

Ok!! I got it!!!

I fix this... but now i have Error 403 in http://area51.leemocms.com/

# RAILS_ENV=production script/about
About your application's environment
Ruby version              1.8.7 (i486-linux)
RubyGems version          1.3.5
Rack version              1.0
Rails version             2.3.5
Active Record version     2.3.5
Active Resource version   2.3.5
Action Mailer version     2.3.5
Active Support version    2.3.5
Application root          /var/www/area51.leemocms.com/htdocs
Environment               production
Database adapter          postgresql
Database schema version   20091227112908

RE: Problem with db - Added by Felix Schäfer about 10 years ago

Have a look for clues in the production.log in the redmine log directory and in the apache logs.

RE: Problem with db - Added by Alexey Popov about 10 years ago

error.log

[Thu Feb 18 05:01:46 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/favicon.ico, referer: http://area51.leemocms.com/
[Thu Feb 18 05:01:48 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/
[Thu Feb 18 05:01:48 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/favicon.ico, referer: http://area51.leemocms.com/
[Thu Feb 18 05:05:48 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/, referer: http://www.redmine.org/boards/2/topics/11532
[Thu Feb 18 05:05:48 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/favicon.ico
[Thu Feb 18 05:05:48 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/favicon.ico
[Thu Feb 18 05:05:51 2010] [error] [client 194.186.53.225] client denied by server configuration: proxy:http://127.0.0.1:8001/favicon.ico

production.log

# Logfile created on Wed Feb 17 18:16:32 -0500 2010

RE: Problem with db - Added by Alexey Popov about 10 years ago

# mongrel_cluster_ctl status
Checking all mongrel_clusters...
mongrel_rails cluster::status -C redmine.yml
missing pid_file: tmp/pids/mongrel.8000.pid
missing mongrel_rails: port 8000

found pid_file: tmp/pids/mongrel.8001.pid
found mongrel_rails: port 8001, pid 28138

found pid_file: tmp/pids/mongrel.8002.pid
found mongrel_rails: port 8002, pid 28141

RE: Problem with db - Added by Alexey Popov about 10 years ago

It Works!!!! ))))) Great....thankes all!

(1-7/7)