Error running redmine at server startup

Added by A S over 9 years ago

Please help, getting this error on startup of mongrel after install of redmine:

account@account [~/rails_apps/redmine]# ruby script/server -e production
=> Booting Mongrel
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
/home/account/rails_apps/redmine/app/controllers/activities_controller.rb:2: undefined method `menu_item' for ActivitiesController:Class (NoMethodError)
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in `require'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:265:in `require_or_load_without_engine_additions'
from /home/account/rails_apps/redmine/vendor/plugins/engines/lib/engines/rails_extensions/dependencies.rb:124:in `require_or_load'
from /home/account/rails_apps/redmine/vendor/plugins/engines/lib/engines/rails_extensions/dependencies.rb:101:in `each'
from /home/account/rails_apps/redmine/vendor/plugins/engines/lib/engines/rails_extensions/dependencies.rb:101:in `require_or_load'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:224:in `depend_on'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:136:in `require_dependency'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:414:in `load_application_classes'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:413:in `each'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:413:in `load_application_classes'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:411:in `each'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:411:in `load_application_classes'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:197:in `process'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
from /home/account/rails_apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
from /home/account/rails_apps/redmine/config/environment.rb:9
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /home/account/rails_apps/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
from /home/account/rails_apps/redmine/vendor/rails/railties/lib/commands/server.rb:84
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
from script/server:3
account@account [~/rails_apps/redmine]# ruby script/about
About your application's environment
Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.3.5
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Edge Rails revision unknown
Application root /home/account/rails_apps/redmine
Environment development
Database adapter mysql

Replies (1)

RE: Error running redmine at server startup - Added by Simo Pylvas about 9 years ago

I am getting the same error, but can't figure which ruby/rail/gem version is wrong and that because i know close to nothing about the RoR..

-bash-3.2$ gem environment
RubyGems Environment:
- RUBYGEMS VERSION: 1.3.7
- RUBY VERSION: 1.8.7 (2009-06-08 patchlevel 173) [x86_64-linux]
- INSTALLATION DIRECTORY: /home/xxxx/ruby/gems
- RUBY EXECUTABLE: /usr/bin/ruby
- EXECUTABLE DIRECTORY: /home/xxxx/ruby/gems/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /home/xxxx/ruby/gems
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- "gempath" => ["/home/xxxx/ruby/gems"]
- "gem" => "--remote --gen-rdoc --run-tests"
- "gemhome" => "/home/xxxx/ruby/gems"
- "rdoc" => "--inline-source --line-numbers"
- REMOTE SOURCES:
- http://rubygems.org/
-bash-3.2$ gem list --local

  • LOCAL GEMS ***

actionmailer (2.3.8, 2.3.5)
actionpack (2.3.8, 2.3.5)
activerecord (2.3.8, 2.3.5)
activeresource (2.3.8, 2.3.5)
activesupport (3.0.0, 2.3.8, 2.3.5)
ffi (0.6.3)
hoe (2.6.2)
i18n (0.4.2)
json_pure (1.4.6)
mysql (2.8.1)
rack (1.1.0, 1.0.1)
rails (2.3.8, 2.3.5)
rake (0.8.7)
rubyforge (2.0.4)

I installed rails 2.3.8 because redmine was complaining that its missing when I ran ruby script/server webrick -e production

Missing the Rails 2.3.8 gem. Please `gem install -v=2.3.8 rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the
Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.

(1-1/1)