Upgrade to 1.2 question

Added by hugo joe about 11 years ago

On Debian Squeeze(upgrade from lenny) with Rake 0.8.7 with the patch in http://www.redmine.org/issues/8588.

When I run "gem install mysql", it shows many lines like "No definition for next_result
". 'mysql' list in "gem list"

When I run "rake db:migrate RAILS_ENV=production", errors show :
/var/lib/gems/1.8/gems/rake-0.9.2/lib/rake/file_utils.rb:10: warning: already initialized constant RUBY
/var/lib/gems/1.8/gems/rake-0.9.2/lib/rake/file_utils.rb:84: warning: already initialized constant LN_SUPPORTED
rake/rdoctask is deprecated. Use rdoc/task instead (in RDoc 2.4.2+)

Best regards

Hugo

Replies (6)

RE: Upgrade to 1.2 question - Added by hugo joe about 11 years ago

The rake 0.8.7 was installed through aptitude.
And rake 0.9.2 shows in "gem list --local" .

How could I deal with the version of rake?

RE: Upgrade to 1.2 question - Added by Alex A about 11 years ago

Try uninstall rake 0.9.2

RE: Upgrade to 1.2 question - Added by hugo joe about 11 years ago

Bad to find that rails 2.3.11 depends on rake 0.9.2.

RE: Upgrade to 1.2 question - Added by Alex A about 11 years ago

I was deleted rake 0.9.2 on Ubuntu, and rails 2.3.11 work fine.

RE: Upgrade to 1.2 question - Added by hugo joe about 11 years ago

sudo gem install rake -v=0.8.7
ERROR: http://rubygems.org/ does not appear to be a repository
ERROR: Could not find a valid gem 'rake' (= 0.8.7) in any repository

Which version should I use?

Thanks

RE: Upgrade to 1.2 question - Added by hugo joe about 11 years ago

When I run "gem install rake -v 0.8.7", it works!
Then I crete a empty file :/usr/lib/ruby/1.8/rake/dsl_definition.rd
Then upgrade goes forward.

Best regards

Hugo

(1-6/6)