rake can't find "i18n" gem even after I install it

Added by Alex Last over 8 years ago

[~/public_html/issues]# cd redmine-1.2.1
[~/public_html/issues/redmine-1.2.1]# RAILS_ENV=production rake db:migrate
(in /public_html/issues/redmine-1.2.1)
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`
[
/public_html/issues/redmine-1.2.1]# gem install -v=0.4.2 i18n
Successfully installed i18n-0.4.2
1 gem installed
Installing ri documentation for i18n-0.4.2...
Installing RDoc documentation for i18n-0.4.2...
[~/public_html/issues/redmine-1.2.1]# RAILS_ENV=production rake db:migrate
(in ~/public_html/issues/redmine-1.2.1)
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`

Replies (1)

RE: rake can't find "i18n" gem even after I install it - Added by Alex Last over 8 years ago

oh, I found it finally:

had to run this in Linux command line before starting "rake":

export GEM_HOME=$HOME/ruby/gems

(1-1/1)