Coderay/redmine_Ultraviolet no code highlight

Added by gogo Tohell over 8 years ago

Before explaining your problem, please add the following information:
- Operating system: Ubuntu Server 10.04.3 LTS
- Database used, and its version: MySql (5.5.17)
- Ruby-aware server used: Webrick (i guess)

About your application's environment
Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.3.5
Rails version 2.2.3
Active Record version 2.2.3
Action Pack version 2.2.3
Active Resource version 2.2.3
Action Mailer version 2.2.3
Active Support version 2.2.3
Edge Rails revision unknown
Application root /usr/share/redmine
Environment production
Database adapter mysql
Database schema version 20100221100219

About your Redmine plugins
Redmine Ultraviolet Syntax highlighting plugin 0.0.3

The Problem: redmine_Ultraviolet Syntax highlighting is not functional. It will add line numbers if you use the "class" modifier, but it won't format code.

examples: While there are no specific instructions for using Ultraviolet with redmine, i assumed I should use the same syntax as coderay.
like (spaces added to pre and code syntax so you could see them):

 < pre >
< code = " cs " >
  public class HelloWorld
    public const string = "Hi there world, how are ya?";
< / code > </ pre> 

  1. The plugin shows up under administrator>>plugins in a browser
  2. You can select a theme under "My account"
  3. I tested ultraviolet as a standalone and got it working formatting a c# file.
  4. No errors occur in redmine's log file. I checked the production.log file and there have been no errors since my original blundering attempts to get it installed(last month)

What I need: Help moving forward. Google and I have gone as far as we can go, now its time to get your help. Even if you don't know a fix, any suggestion or recommendation would be appreciated!

PS: there is some argument as to whether coderay ever worked for us at all...even before the redmine_ultraviolet plugin install.

questions where should the highlighting work? In issue text? Documentation text? Repository (i can see that yours functions)? I just want to make sure I am testing it properly.

Thanks in advance!!!

Replies (3)

RE: Coderay/redmine_Ultraviolet no code highlight - Added by gogo Tohell over 8 years ago

Okay, I guess the Ubuntu package is out of date. It installed redmine version 0.9.3. That may or may not be part of the problem. I am going to go ahead and follow the update instructions to get it to the Latest Stable version 1.2.

I'll be back if that doesn't fix it.

RE: Coderay/redmine_Ultraviolet no code highlight - Added by Chris Martin over 8 years ago

Hey gogo, i'm running into the same problem, but i'm already on Redmine 1.2.0. Did you manage to get this working?

RE: Coderay/redmine_Ultraviolet no code highlight - Added by gogo Tohell over 8 years ago

Hey Chris. Yeah, that mostly fixed it for me. It was still having a few issues but it was permission based. Check in the information page. (log into redmine as admin, go to the admin page.

There are 4 things there. They have a green check if they are working properly and a red x if they are not. My problem was the add-on folder was not writeable. I fixed that and ultraviolet started working.

That being said, I only see it working on the SVN (repository) pages displayed in redmine. The Add/edit issue and documentation pages still use coderay. Can't tell you if that is the intended result or not, information on what exactly redmine_ultraviolet does is few and far between. (I believe it is working as they intend as they are absolutely no instructions on what syntax to use to use it, therefore I belive it looks at filetype to determine that).

Purportedly the next version of coderay will support c#. I hope so!