Internet Explorer cannot display the webpage / After Administrator Login

Added by Massimo Barbera over 10 years ago

Dear all,
I am a complete Redmine newbie trying to fix an issue I can not find root cause of.

I have been performing installation steps described at:
http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_a_sub-URI_on_Windows_with_Apache

If I try to login with administrator account (login: admin, passwd: admin) from the following page
http:\\localhost\redmine
I am redirected to the error page
Internet Explorer cannot display the webpage

While if I perform login to test the installation by running WEBrick web server
(the following command has been performed ruby script/server webrick -e)from page http://localhost:3000/
I correctly login

Note that if now I open a new browser at the firsturl (http:\\localhost\redmine), I am displayed the correct administrator page.

Could you please help me to undserstand what I am doing wrong?

Thanks much in advance!
Regards

Replies (5)

RE: Internet Explorer cannot display the webpage / After Administrator Login - Added by Kevin liu over 10 years ago

Hi Massimo Barbera,

I also met the same issue 1 week ago. I find a fix for it with the following steps:

1. copy the attached file (mongrel_cluster_with_rails_211_fix.rb) to redmin/config/initializers folder
2. rerun the following command in command line under redmine folder

rake generate_session_store
set RAILS_ENV=production
rake db:migrate

Hope it is helpful.
Regards
Kevin

RE: Internet Explorer cannot display the webpage / After Administrator Login - Added by Massimo Barbera over 10 years ago

Hi Kevin,
thank smuch for your reply!

I have tried to perform the steps you suggested and it looks like it works fine until I find a syntax error as a consequence of the third command.

It looks like he's not expecting something with an HTML format but I can't figure out what's wrong with that.

Do you have any idea?

C:\webserver\Redmine\redmine-1.3.0\config\initializers>rake db:migrate (in C:/webserver/Redmine/redmine-1.3.0)
Please install RDoc 2.4.2+ to generate documentation.
rake aborted!
C:/webserver/Redmine/redmine-1.3.0/config/initializers/mongrel_cluster_with_rail
s_211_fix.rb:1: syntax error, unexpected '<'
<!DOCTYPE html PUBLIC "-//W3C//...

RE: Internet Explorer cannot display the webpage / After Administrator Login - Added by Massimo Barbera over 10 years ago

Hi Kevin,
for a certain reason it looks like the attachment you provided me was saved in html format.

So I have created an .rb file with just the content of the script (exctracting from html file the lines numbered from 1 to 83).

Now the commands you provided me work fine, but I still have the original problem: after login I have the error "Internet Explorer cannot display the webpage ".

Not sure how I can proceed now :(

RE: Internet Explorer cannot display the webpage / After Administrator Login - Added by Rodrigo Carvalho over 10 years ago

Hi Massimo,

For me it works just fine. Did you restart your mongrel windows service after running 'rake db:migrate'?

RE: Internet Explorer cannot display the webpage / After Administrator Login - Added by Massimo Barbera over 10 years ago

Hi Kevin, thanks.
I did it and it did not work.

Anyway now I have installed Bitnami stack.

Thanks for your support

(1-5/5)