Code highlighting doesn't work; Coderay or UltraViolet

Added by Bud Bundy almost 8 years ago

Hi,

Ive installed redmine on fresh Ubuntu 11.10. Code highlighting doesn't work. Neither in the repositories, or in the wikis with pre/code tags. I then installed ultravilet plugin - plugin shows up in plugin list as version 0.0.3. Still nothing.

I've read this related thread: http://www.redmine.org/boards/2/topics/27051 and tried:
  • Installed rmagick.
  • Admin/Information page shows all green ticks.
  • There are no warnings/errors in /var/log/redmine/default/*
  • /usr/share/redmine/vendor/plugins/ is owned and writable by www-data (that's the ubuntu's apache user I believe).
  • made whole /usr/share/redmine owned/writable by www-data
  • restarted apache2 service several times
  • /etc/apache2/mods-enabled/passenger.conf does have PassengerDefaultUser www-data configuration
Some versions info:
  • Redmine version: 1.3.2+dfsg1-1~oneiric+1
  • ruby: 4.8~oneiric+1
  • apache2: 2.2.20-1ubuntu1.2

Thanks for any help.

Replies (9)

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by Bud Bundy almost 8 years ago

Nobody runs redmine on Ubuntu?
Everyone has their code highlighting working without problems?
Because I tried again, on another fresh system following this official guide http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_Ubuntu with passenger plugin. Same thing.

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by Bud Bundy almost 8 years ago

Installed 1.4.1 from source (vs Ubuntu apt repository) and code highlighting works.

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by rm user almost 8 years ago

it works but when you copy code it gets copied with line numbers :(

there are at least 4 issues on this topic and nothing is fixed for 4 years.. :(

ultraviolet is not working for me, requires 'uv' file which is not supplied with redmine-1.4

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by Bud Bundy over 7 years ago

Yep, confirm. UV plugin doesn't work. Code copy could be better.

It's a shame really. I switched from trac to redmine. The user management is great, no htaccess files etc. But issues like this are really annoying.

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by William Roush over 7 years ago

Bud Bundy wrote:

Yep, confirm. UV plugin doesn't work. Code copy could be better.

It's a shame really. I switched from trac to redmine. The user management is great, no htaccess files etc. But issues like this are really annoying.

I haven't had this issue, running 1.4.x at work, and 1.1-2.0.3 in various development environments at home, all on Debian, no issues...

What syntax are you using to put code into tickets?

Edit:

Sorry, the original topic of syntax highlighting, or the sub-topic of copy/pasting code?

If it's copy/pasting, see issue #3382, it seems a patch is near-ready as long as someone codes something up that meets the word wrap requirements but doesn't break line number matching or something, and works cross-browser...

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by rm user over 7 years ago

I can confirm UltraViolet is not working on 1.4.4 stable redmine (I was wrong before).

/var/lib/gems/1.8/bin/unicorn_rails must be run inside RAILS_ROOT: #<MissingSourceFile: no such file to load -- uv>

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by William Roush over 7 years ago

rm user wrote:

I can confirm UltraViolet is not working on 1.4.4 stable redmine (I was wrong before).

[...]

Oh I see, the UV plugin.

http://www.redmine.org/plugins/redmine_ultraviolet

https://github.com/epitron/redmine_ultraviolet

Looks like someone will need to get it 1.4.x compatible.

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by Nick Caballero over 7 years ago

rm user wrote:

I can confirm UltraViolet is not working on 1.4.4 stable redmine (I was wrong before).

[...]

I got rid of that error, on 1.4.4, by installing the ultraviolet gem and adding it to my Gemfile. Then bundle install --local. However, the highlight still does not work - although CodeRay does.

RE: Code highlighting doesn't work; Coderay or UltraViolet - Added by Nick Caballero over 7 years ago

Never mind, Ultraviolet works great but only for repository code view - code tags are not highlighted :(

(1-9/9)