priority field in redmine demo

Added by David Morrison about 7 years ago

I'm trying to set up a demo on m.redmine.org and running into a bit of a roadblock. I've created a project and that seems OK. When I try to create a new issue, one of the mandatory fields is "priority", but the drop down list in the web interface is empty. So I can't indicate a priority and this stops me from creating the new issue. I can't figure out how if I've misconfigured things myself (I don't think so) or if there's some problem with the way the demo server is set up. Are other folks able to create demo projects and then create new issues? Any advice?

Replies (9)

RE: priority field in redmine demo - Added by David Morrison about 7 years ago

(My attempt to reply is continually flagged as spam - not sure why)

Thanks very much for the reply. Your tip would make all kinds of sense to me if I were setting up my own server. However, I was following the instructions at on the main page set up a demo environment hosted on m.redmine.org. I could be wrong, but I don't think your advice makes sense in that context.

RE: priority field in redmine demo - Added by Jan Niggemann (redmine.org team member) about 7 years ago

When I try to create a new issue, one of the mandatory fields is "priority", but the drop down list in the web interface is empty.

Please open a new ticket "defect" with category "website".

RE: priority field in redmine demo - Added by Von Slade almost 7 years ago

Because Jean Philippe Lang does not seem to understand the opened issue . . .
Was there ever a solution for this. I am getting the same error today.

RE: priority field in redmine demo - Added by Jan Niggemann (redmine.org team member) almost 7 years ago

I have re-opened the issue but can't check myself. Let's wait.

RE: priority field in redmine demo - Added by Mischa The Evil almost 7 years ago

Martin Dubé wrote:

Maybe you skipped the step that loads the default values in the database:
http://www.redmine.org/projects/redmine/wiki/RedmineInstall#Step-7-Database-default-data-set

David Morrison wrote:

Thanks very much for the reply. Your tip would make all kinds of sense to me if I were setting up my own server. However, I was following the instructions at on the main page set up a demo environment hosted on m.redmine.org. I could be wrong, but I don't think your advice makes sense in that context.

Although *.m.redmine.org is a demo-environment, you do need to load either the default data-set (after registering your demo, first step when browsing to "Administration" => orange box on top of the page) or add your own custom roles, trackers, statuses, workflows, enumerations etc.

RE: priority field in redmine demo - Added by Von Slade almost 7 years ago

Now, I am getting this error: Default configuration could not be loaded: SQLite3::SQLException: table enumerations has no column named position_name: INSERT INTO "enumerations" ("active", "is_default", "name", "parent_id", "position", "position_name", "project_id", "type") VALUES (?, ?, ?, ?, ?, ?, ?, ?)

RE: priority field in redmine demo - Added by Mischa The Evil almost 7 years ago

I've reopened #12950 once again since I was able to reproduce the error reported here by Von Slade.

(1-9/9)