Help - redmine on windows 2003R2 and mongrel_service

Added by Juju Juju almost 12 years ago

Hi everyone, i got few pb to set up redmine on a server with w2003r2
here's some informations :

- Ruby version : 1.8.6
- Rails version : 2.1.2
- Operating system : Windows 2003R2 (win32 version no cygwin)
- Database used : PostGreSQL (8.3) and postgres-pr drivers (i can't install the native drivers)
- Ruby-aware server used: Mongrel

I followed the installation guide. In installed also rmagick. All went ok.
When i try to launch (ruby script/server -e production) in the redmine directory, it launch mongrel, i have 2 error msgbox :
Microsoft Visual C++ Runtime Library
Program c:\ruby\bin\ruby.exe
R6034 - An application has made an attempt to load the C runtime library incorrectly ...
and no error on the dos screen :
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.1.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
  • Starting Mongrel listening at 0.0.0.0:3000
  • Starting Rails with production environment...
  • Rails loaded.
  • Loading any Rails specific GemPlugins
  • Signals ready. INT => stop (no restart).
  • Mongrel 1.1.5 available at 0.0.0.0:3000
  • Use CTRL-C to stop.

redmine is available throug the port 3000

Has someone any clue on this error ?

Then i want to launch as a windows service, so i installed mongrel_service (win32).
mongrel_rails service::install -N RedMine -c "d:\www\redmine" -p 4000 -e production

The service is added but when i launch it, redmine is not available on port 4000
mongrel log :
  • Starting Mongrel listening at 0.0.0.0:4000
  • Starting Rails with production environment...

I tried a lot of things since that last two weekds, and nothing worked :(

can anyone help me ?
thanks

Replies (9)

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by Teddy L almost 12 years ago

My service is running on Win2003 without error.

I think should try to reinstall mongrel, maybe you have some missing dependancy :
gem uninstall mongrel_service
gem uninstall mongrel
gem install mongrel
gem install mongrel_service

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by Juju Juju almost 12 years ago

hi

i tried many times the uninstall / install of mongrel and mongrel service , and the windows service but the problem is still here :(

the log file is very poor and i don't have other log file (servicefb.log as said in this thread http://www.ruby-forum.com/topic/110201)

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by Juju Juju almost 12 years ago

i finally found what was the problem
the 2 errors showed when starting in command line were apparently stopping the start up in service mode, even if the service was still shown as "started".
i uninstalled the rmagick package which was the source of the problem, as everything work now :)

i'll try later to reinstall rmagick

thanks Teddy for your help

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by Teddy L almost 12 years ago

Strange, i have rmagick-win32 2.8.0 working on my server. Have you installed ImageMagick binaries provided in the rmagick-win32 archive ?

http://rubyforge.org/frs/?group_id=12&release_id=30561

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by Juju Juju almost 12 years ago

well i think not, i installed image magic and then used a gem included, but i'm not sure
i add a problem with my first install (in c:\program files, all corrupted as the first gem update, so i uninstalled and reinstalled in c:\ruby), but it's no very important to have rmagick right now for me, so i keep your link and i'll se soon to install it :)
thanks a lot

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by namita nair over 11 years ago

I am facing the same problem i have Redmine 0.8.3,ruby 1.8.7,rails 2.3.2 i keep getting that problem when i start the server but the application is available.The pop of the same comes up again when i access some links like settings etc.

Earlier i did not face this problem with Redmine 0.8.0,ruby 1.8.7,rails 2.3.2

I tried reinstalling the ImageMagick-6.4.8-Q8 but did not work...
Can any one help me out with this.

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by Teddy L over 11 years ago

When i updated my server to RMagick-2.9.0-ImageMagick-6.4.8-6-Q8, i had to install the official Microsoft Visual C++ 2008 SP1 Redistributable Package because the dll provided with the rmagick package was too old.

RE: Help - redmine on windows 2003R2 and mongrel_service - Added by namita nair over 11 years ago

I downloaded the Visual C++ 2008 Redistributable Package (x86) from the below link
http://redux.imagemagick.org/script/binary-releases.php#windows.
The application has started for me without any problem just that I had to restart my system.

(1-9/9)