"no such file to load -- active_support" after upgrade Ruby 1.8.7 up to 1.9.3

Added by Ruslan Yakauleu over 6 years ago

Debian squeeze

Environment:
  Redmine version                          2.3.1.stable.11898
  Ruby version                             1.8.7 (x86_64-linux)
  Rails version                            3.2.13

I install Ruby 1.9.3 from sources then tried to update other parts and now I stopped

# bundle exec rake db:migrate RAILS_ENV=production
rake aborted!
no such file to load -- active_support
/var/lib/gems/1.8/gems/railties-3.2.13/lib/rails.rb:5:in `require'
/var/lib/gems/1.8/gems/railties-3.2.13/lib/rails.rb:5
/var/lib/gems/1.8/gems/railties-3.2.13/lib/rails/all.rb:1:in `require'
/var/lib/gems/1.8/gems/railties-3.2.13/lib/rails/all.rb:1
/var/www/redmine/config/application.rb:3:in `require'
/var/www/redmine/config/application.rb:3
/var/www/redmine/Rakefile:5:in `require'
/var/www/redmine/Rakefile:5
(See full trace by running task with --trace)

# ruby --version
ruby 1.9.3p392 (2013-02-22 revision 39386) [x86_64-linux]
# gem list

*** LOCAL GEMS ***

actionmailer (4.0.3)
actionpack (4.0.3)
active_support (3.0.0)
activemodel (4.0.3)
activerecord (4.0.3)
activerecord-deprecated_finders (1.0.3)
activesupport (4.0.3, 3.2.16, 3.0.0)
arel (5.0.0, 4.0.2)
atomic (1.1.14)
bigdecimal (1.2.5, 1.1.0)
builder (3.2.2, 3.1.4)
bundle (0.0.1)
bundler (1.5.3)
celluloid (0.15.2)
daemon_controller (1.1.8)
delayed_job (4.0.0)
erubis (2.7.0)
hike (1.2.3)
hitimes (1.2.1)
i18n (0.6.9)
io-console (0.4.2, 0.3)
json (1.8.1, 1.5.5)
mail (2.5.4)
mime-types (2.1, 1.25.1)
minitest (5.2.3, 4.7.5, 2.5.1)
multi_json (1.8.4)
passenger (4.0.37)
polyglot (0.3.4)
rack (1.5.2)
rack-test (0.6.2)
rails (4.0.3)
railties (4.0.3)
rake (10.1.1, 0.9.2.2)
rdoc (4.1.1, 3.9.5)
rubygems-update (2.2.2)
sprockets (2.11.0)
sprockets-rails (2.0.1)
thor (0.18.1)
thread_safe (0.1.3)
tilt (2.0.0, 1.4.1)
timers (2.0.0, 1.1.0)
treetop (1.4.15)
tzinfo (1.1.0, 0.3.38)
vcard (0.2.12)

# bundle show
Gems included by the bundle:
  * actionmailer (3.2.13)
  * actionpack (3.2.13)
  * activemodel (3.2.13)
  * activerecord (3.2.13)
  * activeresource (3.2.13)
  * activesupport (3.2.13)
  * acts-as-taggable-on (2.3.3)
  * arel (3.0.3)
  * builder (3.0.0)
  * bundler (1.3.5)
  * coderay (1.0.9)
  * erubis (2.7.0)
  * fastercsv (1.5.5)
  * hike (1.2.3)
  * i18n (0.6.1)
  * journey (1.0.4)
  * jquery-rails (2.0.3)
  * json (1.8.1)
  * mail (2.5.4)
  * mime-types (1.25.1)
  * money (5.0.0)
  * multi_json (1.8.4)
  * mysql (2.8.1)
  * mysql2 (0.3.15)
  * net-ldap (0.3.1)
  * polyglot (0.3.4)
  * rack (1.4.5)
  * rack-cache (1.2)
  * rack-openid (1.4.2)
  * rack-ssl (1.3.3)
  * rack-test (0.6.2)
  * rails (3.2.13)
  * railties (3.2.13)
  * rake (10.1.1)
  * rdoc (3.12.2)
  * rmagick (2.13.2)
  * ruby-ole (1.2.11.7)
  * ruby-openid (2.3.0)
  * spreadsheet (0.6.9)
  * sprockets (2.2.2)
  * thor (0.18.1)
  * tilt (1.4.1)
  * treetop (1.4.15)
  * tzinfo (0.3.38)
  * vpim (0.695)
# bundle show activesupport
The gem activesupport has been deleted. It was installed at:
/var/lib/gems/1.8/gems/activesupport-3.2.13
# ls /var/lib/gems/1.8/gems/ | grep "activesupport" 
activesupport-3.2.16

And nothing to work. How can I fix it? Why new version of active_support is not used?

Replies (1)

(1-1/1)