Can't run on Ubuntu 14.04 LTS and Apache 2.4

Added by Jakub Derdziak about 8 years ago

The message I've got in logs is

[pid 5290] [client 127.0.0.1:46347] AH01215: You did not specify how you would like Rails to report deprecation notices for your development environment, please set config.active_support.deprecation to :log at config/environments/development.rb

I've tried to install passanger via apt-get and gem, still the same problem.

My VHost configuration:

<VirtualHost *:80>
    ServerName redmine.localhost
        ServerAdmin webmaster@localhost

        DocumentRoot /usr/share/redmine/public

    #RailsEnv production
    RailsBaseURI /
    PassengerAppRoot /usr/share/redmine/public

        AddHandler cgi-script .cgi .fcgi
        <Directory /usr/share/redmine/public>
                PassengerResolveSymlinksInDocumentRoot on
                Options -Indexes +ExecCGI +FollowSymLinks -MultiViews
                AllowOverride all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Redmine is installed via apt-get. What am I doing wrong?

Replies (2)

RE: Can't run on Ubuntu 14.04 LTS and Apache 2.4 - Added by Martin Denizet (redmine.org team member) about 8 years ago

Hello Jakub,
You are running in development environment. I think you didn't do it on purpose. You should un-comment the environment declaration such as:

RailsEnv production

I don't know if it will solve your problem but it could be one step in the right direction.
Cheers,

RE: Can't run on Ubuntu 14.04 LTS and Apache 2.4 - Added by Jakub Derdziak about 8 years ago

Thank you Martin for your help. Your solution didn't helped, but messing (again) with VHost configuration I was able to find my mistake. The problem was in line:

PassengerAppRoot /usr/share/redmine/public

Shoulb be:

PassengerAppRoot /usr/share/redmine (and finally it works out this line is not necessery at all).

My VHost no looks like this

<VirtualHost *:80>
    ServerName redmine.localhost
        ServerAdmin webmaster@localhost

        DocumentRoot /usr/share/redmine/public

        <Directory /usr/share/redmine/public>
                PassengerResolveSymlinksInDocumentRoot on
                Options -Indexes +ExecCGI +FollowSymLinks -MultiViews
                AllowOverride all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

(1-2/2)