Redmine 4.0 bundle update requires rubyzip 2.4 which can only be installed if using Ruby 2.4.0+

Added by R Eddy about 1 month ago

When installing Redmine 4.0, 'bundle update' errors out saying it requires rubyzip 2.4 which can only be installed if using Ruby 2.4.0+. Redmine 4.0 requirements state that you could have Ruby 2.2 and 2.3 so I'm not sure why it reports this issue. Is Rubyzip actually required or could I just comment it out in my gem file?
If I upgrade ruby using rvm (rvm install 2.4.0) I have to copy passenger files over or reinstall passenger plus I get a new gem file will all my old gems from my previous 2.3.3 ruby version. Also get this error:
RVM used your Gemfile for selecting Ruby, it is all fine - Heroku does that too,
you can ignore these warnings with 'rvm rvmrc warning ignore /var/www/redmine/Gemfile'.
To ignore the warning for all files run 'rvm rvmrc warning ignore allGemfiles'.

Unknown ruby interpreter version (do not know how to handle): >=2.3.0,<2.7.0ifBundler::VERSION>=1.12.0.

So I may be updating ruby incorrectly if anyone has a better method or if I can just stay on 2.3.3.

Thanks for any help!

Environment:
Redmine version 3.4.13.stable.19478
Ruby version 2.3.3-p222 (2016-11-21) [x86_64-linux]
Rails version 4.2.11.1
Environment production
Database adapter Mysql2
SCM:
Subversion 1.9.3
Git 2.7.4
Filesystem
Redmine plugins:
redmine_dmsf 1.6.2

Replies (1)

RE: Redmine 4.0 bundle update requires rubyzip 2.4 which can only be installed if using Ruby 2.4.0+ - Added by Go MAEDA about 1 month ago

R Eddy wrote:

When installing Redmine 4.0, 'bundle update' errors out saying it requires rubyzip 2.4 which can only be installed if using Ruby 2.4.0+. Redmine 4.0 requirements state that you could have Ruby 2.2 and 2.3 so I'm not sure why it reports this issue. Is Rubyzip actually required or could I just comment it out in my gem file?

rubyzip is required by redmine_dmsf, a third-party plugin.
https://github.com/danmunn/redmine_dmsf/blob/master/Gemfile#L23

I think that adding the following line to Gemfile.local resolves the issue:

gem 'rubyzip', '< 2.0.0' if RUBY_VERSION < '2.4'

Unknown ruby interpreter version (do not know how to handle): >=2.3.0,<2.7.0ifBundler::VERSION>=1.12.0.

Maybe upgrading rvm resolves the issue. See https://github.com/rvm/rvm/issues/3737 for details.

(1-1/1)