Ubuntu 18.04 installation

Added by Lou F 3 months ago

I'm running Ubuntu 18.04 on WSL and have reached step #4. Attempting to run

bundle exec rake generate_secret_token

I get:

Your Ruby version is 2.7.1, but your Gemfile specified >= 2.3.0, < 2.7.0

How do I resolve this?

In addition these instructions are deprecated

bundle install --without development test rmagick

Results in:

[DEPRECATED] The `--without` flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set without 'development test rmagick'`, and stop using this flag

Edit: fixed by changing local ruby environment to 2.7.0.

Replies (1)

RE: Ubuntu 18.04 installation - Added by Liane Hampe 3 months ago

Hi Lee,

Obviously, you have an improper Ruby version. Is Ruby installed system wide or do you use a Ruby version management tool?

Best,
Liane

(1-1/1)