redmine_wk_time install problem !

Added by Kamil AFACAN 7 months ago

I installed this plugin Redmine 4.1.0-8.
During the bundle install I got some warnings. Due to I am a brand new user of Redmine, I could not comment. Continue to migrate.
Now I could not enter some settings. I am sure but I don't how to configure this kind of warnings !
One of them is below. There a lot gem files mentioned like this.

Warning: the gem 'et-orbi' was found in multiple sources.
Installed from: http://rubygems.org/
Also found in: * https://rubygems.org/
You should add a source requirement to restrict this gem to your preferred sourc
e.
For example:
gem 'et-orbi', :source => 'http://rubygems.org/'
Then uninstall the gem 'et-orbi' (or delete all bundled gems) and then install a
gain.

Any help will be appreciated.

wk_time_fault.txt Magnifier (4.53 KB)

Replies (30)

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

Kamil AFACAN wrote:

Dhanasingh Krishnapandian wrote:

then try this command

bundle exec rails server webrick -e production

I tried and copied the result in the attached file.

It says db connection issue

C:/Bitnami/redmineplusagile4108/ruby/lib/ruby/gems/2.5.0/gems/mysql2-0.5.2-x64-m
ingw32/lib/mysql2/client.rb:90:in `connect': Access denied for user 'bitnami'@'l
ocalhost' (using password: YES) (Mysql2::Error::ConnectionError)

can you check your <redmine>/config/database.yml file ?

RE: redmine_wk_time install problem ! - Added by Amutha R 7 months ago

Kamil AFACAN wrote:

Hello

I installed from the beginning and I copied all I did inside attachment file. I am keeping also the other version.
When I face a thinserver prblem I will try this comment.

Last situation explained in the attachement. (due to the limit, splitted into 2 files)

Thanks again.

We have told you multiple times that if you restore data after the plugin install, it won’t work, don’t try that approach. We can’t support that method.

And for the location type, you have to create location types under ERPmine -> settings -> enumeration

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Ok sorry I missed your advice, I won't try it.

Here is the database.yml

database.yml Magnifier (1.38 KB)

RE: redmine_wk_time install problem ! - Added by Dhanasingh Krishnapandian 7 months ago

the host for the production environment says

host: 127.0.0.1

change that to localhost and see if it would work.
And also when you send database.yml, remove the password and send, other people can see it

RE: redmine_wk_time install problem ! - Added by Kamil AFACAN 7 months ago

Mr Krishnapandian

I tried but nothing changed.

I hate to say this but I have to redraw. It took a lot of time of you and me also. I appreciate. Still I want to use this plugin. I will try to downgrade mysql database from 5.7 to 5.6 and use it with the Redmine 4.0 version.
This is also a big headache at the same time I am trying also this opportunity.

If you have any advice for me I prefer to follow that way. After managing this I will try with Redmine 4.0.2.

Thanks a lot for your support.

I appreciate.

1 2 (26-30/30)